Soldier got stuck while eating his food

**Just bought the game, looks great. Played it for 2 hours and unexpected events occured.
One of my soldiers couldn’t stand up from the table when he finished eating food, he got stuck.
Screenshot link.

I think moving crates with food might’ve caused that issue, since
that’s the only activity I was doing right before this happened.

  1. Acquire Large and Small wooden crate
  2. Fill it with food
  3. Try to place it elsewhere right before their launch time

My specs are:

i5 2300 (2.9ghz)
Gtx 760 2gb
4gb (1333ghz) RAM

P.S. - Wish I could upload my savegame file, but new users aren’t allowed to do so.
I’m really looking forward to finding a solution to this, since my warrior incapable of
performing his guarding duties, leaving my village defenceless against angry goblins
and scary looking demon-logs.

P.P.S. - I tried to remove chair underneath the soldier, thought that would fix the issue.
So, it didn’t do anything, but just in case you were wondering why is he floating in air.

Hi @Kestrel, welcome to the forum :slight_smile:

You should be able to upload files now. To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

Have you tried with town alert mode (pressing “R”) ? I’ve managed to fix stuck hearthlings like your footman sometimes doing that. Do you have the savefile that still has the chair?

Unfortunately, I don’t have that “chair save”, but here’s the aftermath one: (4.2 MB)
Didn’t know the autosave feature was turned off by default so I saved as soon as I failed to fix this issue.
I’ll try to get back into the game after a short break and try that alert mode, although I thought it affects
only workers. Also, moving my stuck soldier with manual commands didn’t work (guard area, move, attack).

I’ll post a reply as soon as I try the R button solution.
Thanks for helping me.

After loading your savefile, it got automatically unstuck (saving and reloading usually helps for many issues).

Oh, really? Well, sorry for the fuss, then.
Glad to know it is fixable ^^

P.S. - it had some engine crash reports I copied to my clipboard, but accidentally overwrote them looking for the website. If there’s any possible way to look it up after you closed it, you probably find 4 or 6 pages of programming text in my savegame.

1 Like