Skywalking Bug (someone learnt how to fly)

resolved

#21

Follow up to Lily’s story. As she was heading for the town she was shot by a goblin!. I couldn’t believe it. Just not her day.


#22

i’ve also had this issue, but not that they get stuck in a mountain, my boiz were rescued a good 10 voxels in mid air, by a quick use of “Reset”


#23

I typically give a quick Reset when I see a Hearthling having these problems, too. Sometimes they teleport back into the sky and continue on their flight though! :joy:


#24

i have to say… WTF?


yeah… sure… an ordinary rock…

what are you doing?.. and how… :neutral_face:


#25

So, I just started a new save in alpha 24+, and one of my footmen ran right into the mountain when they fled from an enemy. Now she is stuck there. Is there a console command to teleport her out? I don’t want to dig a tunnel there because I have plans for that area later.

20180610132921_120180610133534_1


#26

ctrl-c to open console then click on the Hearthling and type teleport into the console. It’ll let you place him wherever the ghost flag is.


#27

i has something similar. A hearthling was stuck underground. All Incould see was a “hungry” icon floating just over the ground. In the end i dug up one layer of soil and the hearthling jumped out. Fortunately just in time because he was starting to lose health due to hunger


#28

We’ve only seen that kind of glitch when rescuing incapacitated hearthlings sometimes… Might be a different bug :thinking:


#29

i love those buildings in the background, have you uploaded those?


#30

nahh, too simple to be worthy :confused:
if you want something like that then use the hole tool to remove any piece of roob out of the wall in 4 sides :wink:


#31

man there’s a place for less “extravagant” buildings on the workshop too, i put some basic ass templates on there :smiley:


#32

One of the great things about the new builder is you can have a basic template to use as a starting point and then experiment with paint and add decorations. I :heart_eyes: the paint tool.


#33

One of my Hearthlings was walking on water, and I didn’t see anything weird in it’s logs or pathing. I can’t seem to reproduce it.

Steps to reproduce:

  1. I tried setting jobs
  2. restricted other hearthlings from doing them

Expected Results:
Anything, like walking over water, or through trees, or anything that would denote a pathing issue.

Actual Results:
Nothing that I could catch.

Notes:
It may just be a one off lottery of environment and mods in play, but better safe then sorry.

Attachments:
20180611140448_1

Version Number and Mods in use!
Alpha 24+, Settlement Décor, Box o’ Vox: Necromancer, Stonehearth Doorways

System Information: Windows 10, i3-4170 cpu, 6.00GB RAM


#34

This should be fixed in the next release.


#35

Thank you very much,
I could not recreate it for the life of me.


#36

not fixed in my case


and my save https://1drv.ms/u/s!Asn3lEt-4tOhia8d-h09ESqqcpHjGg
also I use teleport and reset few times because my ling spawn in unreachable place, but when used teleport I always put them on basic level


#37

I have been watching my hearthlings pathing through the ground and through the air, very frequently. So far they’ve only gotten stuck underground.

I hate this bug. Several times I have missed seeing the stuck hearthling in time and I’ve saved the bug for that town. Since I don’t use the master debug tools, it means that I have to start over again.

Now I’m going to wait until the next release, hoping that this bug is squashed.


#38

Hey @Golden / @Nikolay, is this still happening in the latest unstable versions, or are you playing with r860?


#39

I have not seen it on my latest start. :merry: I’m playing with the latest as of yesterday’s game.


#40

Summary:
Hearthlings are going about their day, trying to collect and store items from the ground to my storage building, then I notice a few lings just phase through the second story of my storage building “walking” towards some wood then just stopping mid-air.

Steps to reproduce:

  1. Absolutely No Idea
  2. Maybe try just letting the game run
  3. Better use a two story building

Expected Results:
Use the stairs

Actual Results:
Forgets they aren’t ghosts half-way through

Notes:
I tried a few things to get them down, as they are actually stuck in the air. First I just waited to see if they would path themselves down especially when they get hungry, they did not. Second I tried putting the town in alert mode to get them to path to the banner, they just remained there in the air but they pulled their hammers out. Third I tried putting a fence gate underneath them to convince them to climb down, they are too high up. Fourth I gave in and used build mode to create a simple stair underneath them. The second after I gave the ok to start building the stairs the floating hearthlings fell down into the ground about half way, but at least then they could climb out. Note that they did not actually need the stairs to be built, just the blueprint seemed to trigger them.

Attachments:

Version Number and Mods in use:
Alpha 24, No Mods

System Information:
Windows 10