Seems Like A Memory Leak

Game runs slow after a few minutes of game play
Steps to reproduce:

  1. Build buildings and farms

Expected Results:
Run Smooth Like Before The New Update
Actual Results:
Runs Choppy and Slow
I have only noticed it now after the latest update fixing the buildings not building after being paused.
I took a screen shot of the percentiles

Version Number and Mods in use:
Release 593 and no mods
System Information:

hi, @Dyngarynth. welcome to the discourse :slight_smile:

perhaps you could upload your save to help the devs when they focus on performance optimization

what are your system specs btw? (cpu, ram, gfx, OS, etc)

So I am running windows 10 64Bit, Intel Core i3 550 3.2GHz, 16 GB Ram, GeForce GTX 760. I was running the game at full graphics options, I have tried dialing it back to see if that was causing a problem but it didnt seem to change anything. I did do a game restart and the game worked fine for a minute and then started running slow again. I tried uploading my saved game but was told that I am too new to upload files.

after you make a few posts, it should upgrade your account automatically. or a mod will roll around and change your status. in the meantime you can upload the save game to a cloud sharing site like google drive or dropbox

I don’t know why I didn’t think of this
I believe this is the save file. Thanks for your help I’m addicted to the game already!

it seems the culprit is the monsters’ AI trying to find a path to your settlement. i fixed the problem by destroying the mobs with the “destroy” command in the console (ctrl+c). you can, of course, destroy them using more traditional methods and create a path to them so they stop freaking out.

i hope that helps you continue that save

Hey it works! Thanks alot!