Roofs Removed on Towers


#1

Summary:

Steps to reproduce:

  1. Design a Custom Guard Tower
  2. Save the Game
    3)Save the Template
    4)Instant Build through console

Expected Results:
Guard Tower Fully Built

Actual Results:
Top Layer of the Guard Tower is removed the entire roof have seen this happen twice with latest patch now and if i place a new template the roof is not even there in edit mode but its there on the world that i designed it on.
It did throw me a ton of errors either when i was saving the template or when i tried ib through the console i think it was when i saved my template but i dont have the reports of the errors i think it was 6 tho.

Notes:
I dont think it has anything to do with spiros window mod which is used on this building the medium sized one because during my livestream yesterday i had the same windows it failed with the top just like this but i remade the towers and still using the same windows from Spiros Window Mod and it worked second time

Attachments:
Left Side this is how it’s suppose to look
Right Side Results of placing it down

Results ib commands create it without the top

How it Should Look

Savefile
SaveGameBanto2016.zip (6.3 MB)

Template
building_templates.zip (44.6 KB)

Version Number and Mods in use:
Latest Steambranch 2940

Mods
Edgepieces
Spiros Windows Only one used on tower
Jomaxro Doorways

System Information:
i7 920d0 @3.8GHZ
AMD 7950
Samsung 830 & 840
WD 1TBx2
4TB Storage Drive
12GB DDR Corsair Dominator


#2

Which construction tool are you using to make the roof? (Floor, 2nd Floor, Slab/free builder) If you’re using the floor tools, maybe that’s the cause of the errors. Do you get the same result if you try with the free builder tool (the blocks separate from the house in the building image interface)?


#3

at the top of the tower the roof that’s above all the walls is 2nd floor tool. but at the sides of this there is 1 slab block on the roof that surrounds the whole roof where it sticks out one block and the things sticking up is also slab.

Not sure what this free builder tool is?

Update
tried to some kind of replicate this and none of these structures has this problem
these have no doors or windows so maybe that in some way affects it but very unsure


#4

I have nothing to offer here, I just wanted to say I really like your guard tower designs and I think I will steal the blueprints. :grin:


#5

Thank you : ) feel free to do so heh
This one however at least for me bugs out.

requires spiros mod for the windows


#6

It should be a couple of free voxels stacked up in front of the little image of the house you see when you’re making a custom building–I’m pretty sure they’re a sort of maroon color (I haven’t played for a while due to academic work!) Try making the roof using that and see if you’re still get error messages.


#7

the only thing i think of is the slab tool that is 3 blocks inside of the game but that’s what i used and the only thing you can use to place single blocks on top of each other.


#8

Yeah, that’s the tool I was thinking of. When you said the roof above the walls was made using the 2nd floor tool, I assumed you somehow used it to make everything. Not sure what’s causing the bug, then–I’ve built numerous structures with a Slab roof, and it’s never spat out errors (yet)…


#9

Yeah i kinda had the same experience with no roof problems but started to happen this latest 1-2 builds i think.