Look what happen when i try to build a roof

anyone have the same problem ?
i would like to get some help !
tnx guys (:smiley:

There is definitely something wrong here. It seems the game get stuck when placing the roof itself as no extra walls are created where the wall are up. Also it creates part of your roof inside your wall.

By any chance did you first create your first floor, then second floor , added roof to second floor , created hole for ladder/stairs on second floor and then tried to added the roof on the first floor ? I am not sure, but I can see how that could mess up the engine.

Try to use the ‘ib’ command on the build and see if it solves it.

ib command?
first time i heard about that command :stuck_out_tongue_winking_eye:
how to use that and where?
tnx!

heres thew steps,

  • open the console (left Ctrl + C)
  • select the building you want to be auto-built
  • type ib into the console and hit enter
  • close the console the same way you opened it

those steps should work. the ib command stands for “insta-build” the house will be built without consuming any resources.

1 Like

i tried this command but still not work
i mean this work on full building but not on roof
the command said :“true” but they still stuck

1 Like

hmm… so does pausing/unpausing with the speed settings (not esc) and saving and reloading do anything?

nope…
i mean if i restart the game i cant do anything with the building…

could you provide the save file then? you might not be able to upload it directly to the discourse, if not you could always upload it to a website such as dropbox or googledrive (just to name a few) and provide us with a download link.

i’m sure that one of the members of TR would love to take a look at this, paging @yshan @sdee @Albert

1 Like

the problem is that i cant even save it.
i mean i can reload the game if i click on ALT+F4

but can save the game after this bug

is this the same as this bug then,

agree i think this is it

dont have any clue how to fix this :frowning:

i don’t have anything either… :disappointed:

i’ll page @sdee @Albert @yshan for you…

1 Like

tnx man…!!!

1 Like

Hi there,
Has anyone run into this bug in the latest 14 unstable build?
Thanks
-Yang