Broken Template Placement [Release 720]

Having this problem with a house i just made that don’t want to work :/.
I created this house and saved it as a template and then put my hearthlings to start building it and the top just disappears then i tried to use the template but then top disappears and leaving windows even before trying to build it

Steps to reproduce:

  1. Choose Template Looks Normal
  2. Put Template in World Top Roof and stuff disapears and leaving flying windows and missplaced

Expected Results:
Entire building intact and built the way it’s designed
Actual Results:
Top Part with all the Top Roofs Disappears and leaves the Windows
Windows at the top of the roof was placed with the Placement Hotkey “P” to make them fit the slab. This has worked most of the times for me in the past but not this time perhaps
The House

Broken House when placing it

Not Placed yet on this one

Template Download (49.3 KB)

Version Number and Mods in use:
Alpha 22 Releas-720 (x64)(M)
Settlement Decorations
Café Mod
Mara Rose Container Mod
Sacred Grove Biome
jomaxro doorways
patrol mod
terrain colors
Archipelago Biome

System Information:
i7 920@3.8GHZ
AMD 7950 3GB
12GB DDR3 1600mhz
Samsung 830,840 SSD
Windows 10 x64 Latest

tried removing all the windows that was placed with Hotkey “P” but it gave the same results

tried without all mods same results

tried with new world same results

I was curious, so took a look inside the building template files. It looks like the roof parts were never saved into the template.

There might be more information in the log file from when you were making that template.

1 Like

Hm interesting and strange ^^ i still have the house not fully finished in one save file without placing it as a template and the roof is not built on that one either just disapears.

wonder if i can try connect some slab and it will save :stuck_out_tongue:

Tried to just add slab ontop of the normal roof you could see from selecting the roof when added new slab that they was not selected at the sametime and that other slab was in template if i pressed Build … strange

1 Like

Did you make the template in release720? We had some raycasting bugs that made it hard to make buildings in release 719, which we fixed in 720, but I’m wondering if they’re creating disjoint houses or something.

I think i made it all in 720 but i will let you guys know if it happens with another building again.