Roof's not symmetrical with certain multi-story builds

1 Like

how is the roof messed up?

sorry, im not seeing it :sweat_smile:

the roof is not symmetrical

1 Like

ok now I see. the overhand on the one side is missing, strange I have not seen that happen, dose it stay like that even if you try adjusting the roof height or how it slopes?

yes, even when changing the floor layout from odd to even

it looks like the roof decided its more important then the walls lol
the left side should all be 1 block farther then it is…

I wish I could help more

maybe @jomaxro might be able to help direct the right person to this bug

EDIT: I hope the paging worked for him :smile:

Hey there @Fralee and @krbrowning,

That does indeed seem odd, but I am unfortunately not sure who does the building editor development for TR. I am just going to throw @yshan and @sdee in here (sorry guys if I guessed wrong), and hopefully one of them will have an answer.

PS. (the page worked!)

1 Like

thanks for passing it to someone that might know.
this one is new to me, haven’t seen this one or heard about this one yet

1 Like

Roof stuff! More like @Ponder or @not_owen_wilson. Thanks for pointing it out!


after more testing this only occurs if you try to build a roof on a second story where the all but the outer most blocks of the floor have been removed

the work around is full second floor -> walls -> roof -> remove unused floor

1 Like

looks like it confused interior and exterior walls

Can confirm bug on Alpha 12, release 472, as well as @krbrowning’s observation that build/erase order makes a difference. If you build in the following order, the roofing error will occur:

  1. Draw foundation
  2. Add walls
  3. Add second floor
  4. Erase all voxels on second floor except those on top of the walls
  5. Add more walls
  6. Add roof

However, if built in the following order, the roof works as expected:

  1. Draw foundation
  2. Add walls
  3. Add second floor
  4. Add more walls
  5. Add roof
  6. Erase all voxels on second floor except those on top of the walls

Repaging @Ponder and @not_owen_wilson

1 Like

You get the same behaviour if you build walls manually (not the auto loop tool) and place them in a counter clockwise direction. If you place one wall in a counter clockwise direction then that side of the roof don’t get an overhang.
Haven’t tried what happens if the wall on one side of the building has two parts. One clockwise and one counter clockwise.
I noticed the same behaviour in Alpha 11, so it’s not a bug in the latest changes.

@Agon: So just to be clear…if you place the walls in a clockwise direction…it builds the roof with the 1 voxel overhang?

that sounds like it has something to do with the way manual walls work, and how what side of the wall is considered the outside/inside has to do with which direction you “stretch” the wall out.

1 Like

Yes to both. And in @jomaxro’s method of reproducing it I’m guessing the auto walls (if that’s what you used) got confused by being used on such a narrow “frame” of floor. It doesn’t know if it should make walls around the hole in the middle or around the floor. If it decides to make the walls around the hole then the inside of the loop will be considered the outside of the wall.

It would be good to have a way to switch the inside/outside of a wall, even after it is built. If you get them in the wrong way they mess up the rpg-view (I think it’s called, where walls are hidden if the camera is on the outside of them).

It would also be good to have access to the erase tool after placing the roof, to be able to remove parts of the overhang.

1 Like

being able to erase the slabs and the walls would be nice, unless im missing something i cant seem to erase them using the eraser button

Being able to toggle inside/outside/internal(ignore for the roof tool) would be very useful


Still an issue #a14r524::tag