Rivers mod 🗺


#41

@BrunoSupremo hey bruno, talking about biome’s we have water, but no lava. could someone mis-use water in a hacky way to get lava?


#42

er, recolor it to be red and intransparent.


#43

if it was that easy, inb4 someone makes erebus/the underworld/


#44

I’m pretty sure I’ve seen someone try that before … it was probably @BrunoSupremo. But if it happened it was a long time ago, so I don’t remember the details.


#45

Yes, here:

Now it is even easier. In your biome, at landscape.water.color, change its value to something like #cc4422. Done.
The swamp water is brown and opaque, so it is not really something new either.


#46

thats prety cool actually. no mixed fluids though i guess?
no water2 to recollor and keep the normal one water-y :wink: ?


#47

No, that is simple a recolor of the basic water.


#48

fair enough. still prety cool that its possible…only downside would be hearthlings would still try to swim in it ;’)


#49

omg update with the code added to my world_gen makes my biome look AMAZING! Thanks @BrunoSupremo



#50

I need that biome. That looks amazing


#51

I pushed it for @OwlGo to add into the standalone version on the workshop. Enjoy :wink:


#52

Which biome is that?


#53

https://steamcommunity.com/sharedfiles/filedetails/?id=1379759521


#54

Totally gonna give it a spin :slight_smile:


#55

wait like 20 minutes or so while Owl actually updated the workshop mod to have the rivers bit in it. Then of course as long as you have this Rivers mod it will work just fine


#56

And @BrunoSupremo feel free to delete our conversation if you need :wink: apologies for flooding this post :stuck_out_tongue:


#57

I’ll wait till the rivers mod is also on the workshop :slight_smile:


#58

I just started my first go with the Northern Alliance in the Misty Woods, rivers mod and giant map enabled, and got this error in the map generation screen:

Summary

release-874 (x64)[M]
…nehearth/services/server/seasons/seasons_service.lua:129: variable ‘season_config’ is not declared
stack traceback:
[C]: ?
[C]: in function ‘error’
radiant/lib/strict.lua:31: in function <radiant/lib/strict.lua:29>
…nehearth/services/server/seasons/seasons_service.lua:129: in function ‘_load_season_config’
…nehearth/services/server/seasons/seasons_service.lua:36: in function <…nehearth/services/server/seasons/seasons_service.lua:35>
[C]: ?
[C]: in function ‘trigger’
radiant/modules/events.lua:55: in function ‘trigger’
…server/world_generation/world_generation_service.lua:105: in function ‘_setup_biome_data’
…server/world_generation/world_generation_service.lua:58: in function ‘create_new_game’
…vices/server/game_creation/game_creation_service.lua:143: in function ‘create_new_world’
…vices/server/game_creation/game_creation_service.lua:178: in function <…vices/server/game_creation/game_creation_service.lua:162>

Only other mod I’m using is Lostems but that shouldn’t interfere here. Only guessing it has to do with either rivers or giant map. Mybe it’s the game itself, not sure.


#59

Neither. It is the biome fault.
No. Wait, I need to update the giant mod too. Nope, I was correct, just the biome fault.


#60

There was a bug in supporting biomes that don’t specify weather/seasons. That is fixed in the next release.