[Res][1687] Crash on load in res_manager.cpp:160

resolved

#1

Here’s the error:

If I switch to no beta, it works just fine. Switching back to latest again results in the same error.


#2

hey there @HamoPeche… can you provide us with your system details (CPU, graphics card, memory)?


#3

If your switching between the steam versions to use Candledark I’ve found they won’t work, have to delete Stonehearth folder and reinstall which ever version you want, clean install each time.

Something hangs around in each install that makes it crash like that if trying to switch.


#4

oh wow… excellent catch! :+1:

@HamoPeche, were you perhaps trying to run the mod? its definitely not compatible with the unstable builds…


#5

No, I wasn’t trying to use Candledark, or any other mod. As you can see from the error message, the issue relates to a missing file. I’ll post computer info shortly, but the issue is a deployment issue.


#6

Try verifying your local files through Steam. I’ve run into this with Steam numerous times on many different games.


#7

I’ll try that, I suppose, but I’ve already tried removing all local content and reinstalling. It will have to wait until after work.

Surely it wouldn’t matter that my Steam installation isn’t on my C: drive, right? Surely?


#8

I don’t think that would make any difference but then again I have my steam games spread across 2 x 2tb hard drives so who knows for sure? :smiley:


#9

Never been an issue for me.


#10

@HamoPeche, this has happened to us here on the dev team too, so you are not alone. :wink: We hope a pending fix to the resource manager (paging @not_owen_wilson) will help, but until then, @Unatan2 mentioned, try uninstalling SH via Steam and then reinstalling.


#11

No dice. I keep getting the same error when I enable latest builds. I removed local content (the Steam term for uninstalling), and reinstalled, with the same result. I assume the assertion is failing because the folder path doesn’t exist (it appears to be a source tree path). There’s no res_manager.cpp in my Steam folder.


#12

Didn’t use Steam to uninstall, just flat out delete the Stonehearth folder for a clean install.


#13

Aha. That seems to have done the trick. So much for “delete local content” actually deleting local content. sigh

Anyway, thanks. Looks like I can at least launch the game now.