[Request] Block mining doesn't "snap"

I guess this goes in the modding category.

Does anyone know how to stop the 4x4 mining section from “snapping”? I would rather be able to start the mining from wherever but I can’t find the part of code that controls that feature. If someone could either point me in the right direction or if the change is already made, show me where, I would appreciate it.



hey there @user5754,

though i personally dont know where to begin with this, i’m sure @Drotten will be able to help you out here.

Well, I haven’t played around with the mining tool so I wouldn’t be able to give you a satisfactory answer. But I’m going to page @RepeatPan as he made a mod before (can’t remember where to it is though) that enabled the user to mine out smaller blocks (this was before the 1x1x1 mining tool was available), so he’d be able to answer that better than I can.


The code actually truncates your position down to the next multiple of four. I think it would be possible to provide a tool that doesn’t, as far as I can tell the code should mostly only be present in the selection of the area, so only the selection is actually “snapping”, but the digging itself could be whatever offset you want.

I don’t have my environment set up, but you probably want to look for “mining”, or something like “select area” or select rect… I can’t recall the proper naming. It’s in a client sided lua file and the call chain starts with a callback handler.