Remove unfinished building - additional info

So I have a building, half built, where it appears the hearthlings have given up on it. It has been at least 5 stonehearth days, and nothing happened to it. When I click the building, I can pause it, but that’s pretty much it. If I use the destroy command on all the parts, will it actually remove the building, or will the game still think I have an unfinished building?

It will completely remove the building. Alternatively you could use ib.

I’m not familiar with ib (although I’ve seen references to it in some discussions). Could you redirect me to where this (and other) commands are explained by any chance?

So I figured out the ib command. Selected my unfinished building, ib’d it, made sure all the necessary materials, decoration and furniture were still in inventory, clicked on finish building, but nothing happened to it.

In the meantime, I got my guildmaster done, so I placed it down, got my visitor, got my tier 2 buildings available. So I decided to build an Inn, the builders went over and started building it, then night came, they went to sleep, and never went back to the building. Now I have a bunch of people that could be building that are just idle.

I also noticed that nobody is mining anymore, even tho I have a very accessible mining area, with idle workers. Do they all get lazy after sleepy time or something?

You can use help in the command console to review commands.

On the building not finishing: I have had a few problems where the game didn’t automatically update where the scaffolding should be after my hearthlings finished a part of the building, simply reloading solved that issue because the game updated how the scaffolding should look so the hearthlings could reach the building again

I have 3 buildings unfinished. The most built one is the one that 's been sitting there for a few days. The other 2 are attempts that I have made to start new buildings that were abandoned when bedtime came.

And now, the 2 “new” buildings are being built, but still not the old ones. The only change I have done to trigger the restart of the building is to remove a area that was marked for mining. I guess I’ll wait and see what happens once those 2 buildings are done, maybe the 3rd one will get built as well.

As for the mining area that got removed, turns out that I thought it was accessible, but they were trying to get to the top of the 4x4x4 block and had no way to get there. Once I built a ladder, the mining people went there, and the builders went to the house. I’m still unsure why one had anything to do with the other one tho…