[Rayya] Forge Building Bug? - They won't build past 75% completion!



So I’ve tried to build this building twice now. (As in I halted progress and destroyed the first building, and tried again)
I have double the supply of everything for this building, yet…
My builders won’t build my forge building.
I’ve even strictly made their tasks Building only, and I’ve even seen if I started another building would that maybe do something.

Nope, They just go and build that building and continue to ignore my forge building.
It’s more than halfway built, but none of my workers will touch it.
Has this happened to someone else?



Could you provide a screenshot ?


Yes, sorry, forgot about that;;
Here are two screen shots

  1. https://i.imgur.com/rH7dyFM.png
  2. https://i.imgur.com/dLzRGVo.png


Hey there @Yuveria, welcome to the Discourse :smiley:!

Can you upload your save with the stuck building so we can take a look? If you could also verify the exact version of the game you’re playing, and any mods you’ve installed, that’d be appreciated.

To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.


I’ll be able to fiddle with that later tonight. (PST)


@jomaxro Sorry for the delay!
I took a break from that file and started another one and got caught up in the game.
I started two new games since yesterdays post, and what I’ve seem to come across is I’m only having this problem with Rayya’s in the desert environments. I haven’t tried Rayya’s in the woods yet, but Ascendancy in the woods seem to have no issues with buildings.

Rayya’s buildings seem to be buggy.
The second Rayya/Desert game I started won’t finish the custom building even though I have all the needed supplies.


Rayya’s Forge Building File
1492372853455.zip (8.6 MB)

And just in case the second file with a similar bug will help, here’s today’s file, with the Rayya’s not finishing the custom building.
1492474888107.zip (7.1 MB)

Once again, sorry for the wait! Hopefully we can figure this out and fix it :smiley:


I can’t share a savefile, but last night I was playing with family members and one of them hit this bug twice. The forge template from the Rayya’s Children faction would not finish building. Since both times the build stopped with only a couple of windows, one door, one lantern, and a bed not yet placed, it seems to be bad scaffolding. :forlorn:


I have the same thing just happen to me. When I destroy the building I get the error posted below. Also three ladders seem to stay in mid air until I manually add new ladders to take them down.

release-707 (x64)
…hearth/components/scaffolding/scaffolding_region.lua:791: attempt to index field ‘_owning_scaffolding’ (a nil value)
stack traceback:
radiant/modules/common.lua:245: in function 'report_traceback’
radiant/modules/common.lua:256: in function <radiant/modules/common.lua:250>
…hearth/components/scaffolding/scaffolding_region.lua:791: in function 'instance’
radiant/modules/events.lua:291: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:265: in function 'xpcall’
radiant/modules/events.lua:285: in function <radiant/modules/events.lua:251>
[C]: in function 'destroy_entity’
radiant/modules/entities.lua:83: in function 'destroy_entity’
stonehearth/services/server/build/ladder_builder.lua:142: in function <stonehearth/services/server/build/ladder_builder.lua:123>
[C]: in function 'destroy’
stonehearth/services/server/build/ladder_manager.lua:71: in function '_destroy_builder’
stonehearth/services/server/build/ladder_builder.lua:455: in function '_check_if_valid’
stonehearth/services/server/build/ladder_builder.lua:325: in function '_update_build_mode’
stonehearth/services/server/build/ladder_builder.lua:114: in function <stonehearth/services/server/build/ladder_builder.lua:113>


@Golden Glad to know I’m not alone! Do they also run into this issue while building custom buildings??


The problem with the Rayya’s Forge is the gap between the red clay wall and the beams above it. The hearthlings don’t build the scaffolding all the way up to the top of the wall because they need head clearance so they can’t reach the little sections of ladder stuck under the beams.

Red Arrows are the problems. Build ladders where the yellow arrows are on the INSIDE all the way up to the top of the clay wall BETWEEN the beams. That should solve your problems here.

Next…you need a ladder so the hearthlings can reach the scaffolding around the back of the building on your other save.

Once that’s done they’ll remove the rest of the scaffolding for ya. BUT you have 2 more issues…
Build a ladder on the first floor up to the top of this pot so they can reach the ladder to place the lantern. Wait for them to get rid of the tall ladder then manually remove the smaller ladder.

This one I couldn’t fix. :forlorn: I tried undeploying the bed over it, the bed next to it, and the wall planters in case they were banging their heads and they still wouldn’t place the floor tile. Hopefully someone else can fix that one for ya.

It can be frustrating, but hang in there. You’re doing a great job! At the moment Hearthlings are a bit stubborn and like to do things in order. So if they can’t reach scaffolding they wanna remove they give up unless ya give em a little boost. Sometimes they get a bit ahead of themselves and place things out of order, like the pot and the lamp on the first level. I just give em a pass for that kinda stuff cause they’re so darn cute lol. Enjoy your game and keep up the great work!! :jubilant:

Hearthlings Refuse to Finish Building

I’ll keep this in mind when going back to my Rayya file! Thank you so much :jubilant:


No problem! Glad I could help!! :merry: