Random runtime crashes saying graphic card had to be closed down


#1

Hey im getting several issues that make this game completly unplayable to me. Every time i start a game it works like 20 minutes ? then it crashes telling me that runtime caused trouble closing the graphic of my radeon 4870. When i restart the game it crashes faster now and it sometimes takes only 3-5 minutes.

there are some small issues like crashing when i stop building or something is glitching but this repeating crashes for like no reason are so annoying. I know some little IT so i tried several runtime packages. updated my card driver and the game. I have a clean non changed Windows 7 profile to work on documents and it seems like stonehearth is running for a longer time there till it starts to crash.

i searched for a faq that tells what runtime and other packages have to be installed to make it work smooth.

Windows 7 64 bit
radeon 4870 2gbram
16gb ram
amd bulldozer 3,2ghz per core quad

plz plz help me. it destroys my love to this game and i stopped trying to play it


#2

I’m not where I can look right now but check the ATI website for updated drivers. Don’t use the automatic driver checker; it won’t always work.

Updated ATI drivers fix a lot of these kinds of problems.


#3

I’m guessing it’s out of date graphics card drivers.

Assuming you’ve got a Radeon HD 4870, then have a look here:

http://support.amd.com/en-us/download/desktop/legacy?product=legacy2&os=Windows%208%20-%2064

Should be the latest drivers for your card. Let us know if that doesn’t help though :slight_smile: !


#4

ok i tried. it looked like there was no new driver and it keeps crashing. Is this game designed for Geforce cards only ? when i watch streams of this game they can play for hours. i have to save every 3 minutes… sometimes it even crashes directly after it is done loading. the unstable betarelease crashes a little fewer,


#5

No, it definitely runs fine on various AMD cards (if the drivers are up to date), so your situation is certainly unusual.

Going to give @sdee & @ponder a poke (and maybe @not_owen_wilson for when he gets back), maybe they can shed some more light on this :confused:


#6

well, okay.
I took all windows updates today. i tried to run it in compatibilty mode. updated everything i could imagine what causes this bug. Im sad right now. I dont think i will care about new implements when i cant play 3 minutes without crash. I pretty much regret the investment.


#7

@Devi, I’m sorry it’s been such a bear for you. One more try: can you send us your User ID? You can find it in the newest version of the game (on unstable) when you hit and hit the support/file bugs button. That way we can see what crash is happening here. If you prefer you can send it to me in a PM.

Worst case scenario, you can ping HumbleBundle (since they run our store) and ask them for a refund.


#8

590d c23c-42f9-11e4-90f9-00ff72600c00
it is. i cant figure out how to send a pm. dont know what u can do with that number

edit.

it seems like the bug has slightly changed. it now happens very fast after the map is loaded and its not more than 1 minute. its now completly impossible to play…

i have seen some bug reports that sound like this. will look through them now…