[r345] Manually extending an auto-placed ladder makes it unremovable

Hi all. Long time lurker / player but first post here :smile:

It seems that if you have an automatically built ladder (e.g. from placing a lantern on a wall), manually extending the height of this ladder renders the entire thing unremovable.

After the item that the ladder was auto-built for is handled, no pawn comes along to remove the ladder afterwards, ever.



Did you try building additional ladders near the ladder in question? Hearthlings are a little finicky with building and disassembling things at the moment. Sometimes they need a block or ladder at a certain height to remove ladders or pick up materials on the ground (usually it’s a y-axis problem). Try building some next to it to see if that helps them.

Another potential culprit is lua/pathfinder overload. If the little bar in the lower right is totally blue/yellow, the Hearthlings might not be able to recognize the need to delete the ladder and will just sit around. This usually happens later in a game, when lots of things have been done.

If neither of these things, it could be a bug. Do you have a screenshot showing the ladder?

1 Like

Thanks for the reply,

Yep, I did try building more ladders, but it didn’t seem to help. Pathfinding might be involved but I’m not sure. I’ve tried to reproduce the bug as clearly as possible and show what’s going on:

Checking the workload percentages does show pathfinding spike for a while, but there are also periods where everything looks idle too. Not really sure how conclusive that is.

Yep, it’s a bug (which I don’t believe has been reported yet). If it was a y-axis issue, those extra ladders would have fixed it. Lua and pathfinder likely aren’t an issue, either–spikes are normal. We’d be looking for the entire bar at the bottom to continuously be buried in blue or yellow.

I think I see what the actual bug is here:

When you add some more to an auto-generated ladder, the game takes removal duties away from the hearthlings. The player should now be in control of the removal of the ladder, but the game fails to assign control to the player (there is no red X icon on the info bar for the ladder).

Does that sound right?


Yes, that’s exactly it. :slight_smile:

1 Like

Now thats a bug. added another ladders on ladders (extended them) and thats what happened. Cant do anything with them…

Ladder problem