[Question] Why is my workers doing building work?

I have 9 workers and they are not putting on the roof of a building and IDK why that is?

here is an image for the building.

Idiot question, but did you place the roof during the building edition, before to start it?

Also, do you have all the supplies required to build it (wood, stone…)?

I have everything and the roof is placed on during the design part of the building but they would not build it.
I did other building work and they finished that?

By “that”, do you mean the one they wouldn’t finish in the first place, or the new one you’ve made?

the fortress wall in the picture they can’t finish so I thought maybe if I did something like a road or another building I need and see if they complete that and they did but still can’t finish off the roof on the picture building.

Looking from that angle it is likely that they can’t climb there. All ladders to reach the roof are starting at the bottom of the lake. Build a ladder to the bottom of your lake so they can reach those ladders later and climb them


there are 3 ladders at the bottom of the lake that I have put in but still no because that is what I thought in the first place.

Uhm, there is that left corner, the grass part can’t be accessed. But I doubt it is it.

I recommend uploading your save file. This way other can check it in real time from all angles and find the right solution for you.

I know ideally they would figure it out by themselves. But for now, in these cases we need to interfere.


@BrunoSupremo I made sure all the blocked spots had ladders and it worked :slight_smile:

but I have this error but keep getting it?

release-687 (x64)[M]
@stonehearth/components/ai/ai_component.lua:598: (2761 Emmy Hart) has not yielded after 10 ai spins. Are they in a bad state? Last abort reasons: <destination (6973073 stonehearth:decoration:firepit_seat) is no longer valid at start. filter description: find lit fire (x10)>
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:456: in function 'verify’
stonehearth/components/ai/ai_component.lua:598: in function <stonehearth/components/ai/ai_component.lua:537>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
stonehearth/components/ai/ai_component.lua:537: in function '_thread_main’
stonehearth/services/server/threads/thread.lua:273: in function <stonehearth/services/server/threads/thread.lua:270>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
stonehearth/services/server/threads/thread.lua:270: in function 'f’
radiant/lib/env.lua:15: in function <radiant/lib/env.lua:14>

There’s no reason to be ugly. We were all new at one point.

Quote from myself here:

Huh? I was just questioning, i didn’t mean to be an ass. Sorry if you did misunderstand me.

Just cuz you called it an idiot question.


you meant YOUR question was the idiot question!

1 Like

Yes that’s what i meant. Well english isn’t my native language so my grammar can be confusing.
But i wouldn’t hurt anyone for sure.
Anyway… Let’s go back on the topic. :blush:

Yes. Sorry about that :confused:

save, that building, than remove it and place it again, it helped when i was building my great wall

This is very strange as all ladders and scaffolding is touching the ground and everything is accessable but they will not finish the building?


[details=Save file]1485211566521.zip (5.8 MB)

Could anyone shed some light on this please?

Check through the whole build, see if there is a ladder in a window, or something. Also use all 3 visions to make sure it didnt get left in a wall either