Problem with building structures?

release-687 (x64)[M]
stonehearth/components/scaffolding/scaffolding.lua:316: attempt to index field ‘_blueprint’ (a nil value)
stack traceback:
[C]: ?
stonehearth/components/scaffolding/scaffolding.lua:316: in function 'get_blueprint_region’
stonehearth/components/scaffolding/scaffolding.lua:357: in function ‘set_scaffolding_region_as_destroying’
…hearth/components/scaffolding/scaffolding_region.lua:746: in function ‘_start_erasing’
…hearth/components/scaffolding/scaffolding_region.lua:227: in function <…hearth/components/scaffolding/scaffolding_region.lua:220>release-687 (x64)[M]
c++ exception: lua runtime error
stack traceback:

Welcome to the forum, @MikeyMan :slight_smile:

Could you upload the savefile where this error is happening?
To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

@Relyss ♻ Turn-based multiplayer using a shared save file (Ascendancy, Temperate 🌲 ) is having the same error issue. Perhaps looking into that one too please?

Not exactly the same error, but thanks for the reference.

I’ve seen these “attempt to index field ‘_blueprint’” and “attempt to index field ‘_bp’” errors for a while, the problem is that they are coming from different files each time, so I’m never sure when to merge the reports. :sweat:

1 Like (7.4 MB)

This is the game that is causing the errors, any idea whats causing it specifically?

Maybe (I’m not sure) it’s that thing at the back of the town, which has all the floating scaffolding:

What was there before? Is this an in progress building that you removed?
Did you use any debug_tools / console commands?

yes it was in progress being built and the same error occurred multiple times so I attempted to remove the building but the scaffolding decided to stay, I also did not use any debug tools

3 posts were merged into an existing topic: Diagonal Foundation breaks Wall generation