Playability of the game


#1

Hey there,

I’ve been lurking around here for some time and trying out every version of the game. Every time I try to play it, there are a few issues hindering me from playing. Looking around, there are a lot of threads describing bugs I also encounter. So I want to focus here on combining these bugs in a gamebreaking way. When I play, I try to play as long as the game let’s me. So i will try and accumulate a list of bugs here that render the game broken, if possible with a link to the bugs thread. I will also record my play sessions on youtube for you all to see and review. Most of these bugs leave no stacktrace, so there is nothing for me to say about them other than the things I was doing. Most of the time I stop playing when the UI crashes and menus are not responding or not even appearing.

I have placed this in the [active bugs] category because i thought that would fit… And i am surely playing the latest steam branch.

My first two plays on the new update 114 ended as follow:

  1. About 20 goblins killed all my people. Idling goblins everywhere, no way to exit, no menus responding. [Alt+F4]
  2. Selection menu vanished, can’t click on anything. Game unplayable. Exit game works, but save/load was not responding.

Unfortunately I have no video for these plays but i will add more playthroughs whom I will record.

My list of found bugs:

  • Random UI craches / not responding / not there / no redraw / artifacts
  • New townspeople not added to any list
  • When the current crafting order is missing items, changing the crafting order renders the crafting table completely useless (until missing item resolves). Deleting the order does not stop the crafter from crafting said item.

There surely are a lot more, I will expand this list as I play.

Will now start some recorded playthroughs!

Regards,
Kostronor

PS:
I play on a Win 7 PC with I7 377k and GTX 680


#2

so i see that the 1st 2 plays have been discussed before as well the 1st 2 bugs have been discussed as well. the last bug is one that i meant to put on soon with my videos im making currently.


#3

This one I think is due to the general UI freeze that occurs upon the joining of a new citizen. The first one you listed there may thus be related also. A save/load fixes this issue—well, it’s a workaround, I should say—but unfortunately save/load is itself associated with a bad bug presently. The solution for now (until the dev team fixes either or both of these) is to save often, so that if a particular save is broken, you can load a previous save in that world, and you always have something to do when the UI freezes.


#4

My first video recording I was doing until seconds ago also had the new citizen bug. I have it at YouTube where you can see what UI works and what not. The save I did there was not saved and could not be loaded (as if I hadn’t saved at all). Will try a second attempt without any new citizen. Let’s see, how far we get this time.

Also, i have an addition to your bug @Phagocytosis
In this video YouTube my soldier died and the UI crashed the same way it did, when new people were joining…