Placing building template will do nothing, just placeholders for doors and windows

I have been playing a save for a while and placed many buildings but now I see I’ve tried to place a building template but only the windows and door have their placeholders - the rest of the house is not there. This happens for both custom saved templates and built-in ones. There is an error when i click on say the window:

release-610 (x64)
radiant/modules/client_entities.lua:45: attempt to index local ‘entity’ (a nil value)
stack traceback:
[C]: ?
radiant/modules/client_entities.lua:45: in function ‘get_component_data’
…earth/services/client/build_editor/doodad_placer.lua:13: in function ‘go’
…ervices/client/build_editor/build_editor_service.lua:155: in function <…ervices/client/build_editor/build_editor_service.lua:153>

I actually managed to remove the parts of the building by using “remove building” on each one-by-one, however they now appear to just be invisible as I cannot place a building at the same location. The next time i place a building it recreates the windows and doors but does not place the new building I have selected. Please see the below screenshot to see what I mean.

Steps to reproduce:

  1. Not sure, just kept playing a save until eventually bugs prevented me from building any further.

Expected Results:
Building plan works as normal

Actual Results:
As above, just the windows & doors spawn, nothing else.

Nothing further to add


Version Number and Mods in use:
Alpha 17 Stable, release 610 (x64), no mods

System Information:
AMD 6350 6 core, 8GB RAM, 512MB SSD, AMD R9 380


Have you tried saving and loading/restarting the game?

Yes I have, in fact I reloaded the game again today (I noticed the issue a couple of days ago and started another game), and I was able to remove the items but it seems they don’t actually get removed as I can’t build anything where they are.

That’s odd, i had some similar issues before, but i somehow managed to get around it(not sure how, though)

Paging @yshan

I think a fixed a similar call stack in the A18 build but not sure if it is pushed yet. Perhaps update to A18 and let me know if that fixes it?
Thanks for reporting this @kickback


Hi Yang,

Thanks, I updated to A18 and it is much better. It was possible to remove the placeholders just by clicking them (but got error 1 when clicking on them) and I could place the building template (but a further 9 errors popped up regarding “entities not existing, did you delete them with the console command?”).

Despite the errors this has fixed it and the hearthlings are happily building the house. I’m pretty sure the errors exist because of the issues I had in A17

First error:
develop-3131 (x64)
radiant/modules/client_entities.lua:40: attempt to index local ‘entity’ (a nil value)
stack traceback:
[C]: ?
radiant/modules/client_entities.lua:40: in function ‘get_component_data’
…earth/services/client/build_editor/doodad_placer.lua:13: in function ‘go’
…ervices/client/build_editor/build_editor_service.lua:155: in function <…ervices/client/build_editor/build_editor_service.lua:153>


A note with A18 - I probably need to do another bug report but the hearthlings do not move objects, they will just find an object which matches that description and place it at the new location (even if it overlaps the old location). If it does not exist, I have to return to stockpile, then someone comes along and places it at the new location.

Thanks for your help with the first issue though :slight_smile:


So i have a template that does this. one i made yesterday.
Im on latest alpha buiild ( release 663)

bit background story here. was making this building and i ran in to a bug i had a few times before that will prevent me from adding any blocks to a building. Normally i can fix this by just making a save and reload.

So i did that but still cant add to the building, so tried to save the half finished template so i could remove the building and place it again, but i just get the few walls and windows placed from the template.

When i logged out tho game updated.

theres the template i tried loading a new game and place it there and got same issue.

i also included the save game with the building where i cant add on it. As in before i made it in to a template.

(save game gets an startup error caused by the large castle, if you remove that startup error goes away, its reported in another post)

playing a bit more around with the building before i made it in to a template i can still delete stuff on it.
but if i attempt to add slabs to it. building mode locks up completely and wont let me do anything.

1 Like