No Promotion Menu button


  • Job promotion button (the one to get to the UI) and the UI don’t show up.

Steps to reproduce:

  • Start a new game and open the Citizen menu or click on a Hearthling

Expected results:

  • Being able to see and click the button to give Hearthlings jobs/ to promote them (at least to get to the UI)

Actual results:

  • The button is not there


  • mods installed
    • Box o’ vox
    • canyon biome
    • greeklings
    • hunting for all
    • Kingdoms of Veloren
    • Nordlingmod
    • Omniterrain Biome
    • Smart Crafter
    • swamp biome + Firefly Clan + Biest tamer
    • the game plague
    • the silent woods
    • unit frame plus
  • my friend plays with these mods no problem at all
  • current version
  • happened first time in MP (2nd game)
  • occurs in every new game I start

pls help me I want to play this game again

Here some screenshots that show my problem!

1 Like

It’s due to some interaction from one of the other mods with UnitFramePlus. UnitFramePlus removes the default promotion button from that window, because it adds a command to the hearthlings to do that same function, which then automatically shows up in that window in addition to on the unit frame in the lower left of the screen (and otherwise there would be duplicate buttons in the citizens view). The way it adds this command to all hearthlings is by mixing into the "stonehearth:mixins:base_human" alias. I suspect that one of the other mods is loading after UnitFramePlus and either overriding base_human completely or overriding/deleting the commands array that’s set up in the "stonehearth:commands" component data.

1 Like

Update: The problem seems to only be with the northern alliance

1 Like

NA shouldn’t be overriding base_human, so I don’t know why that would cause the command that’s being added by UnitFramePlus to not show up (you can see there isn’t a big hammer icon in the lower left next to the book icon, directly under the health). The promotion button being present or gone in the citizens window wouldn’t be directly related to NA, but rather to hot-loaded UI manifests and how they interact with the patch the UnitFramePlus makes to get rid of the button.

1 Like

Try removing mods and see if it solves the issue.

1 Like

I tried, nothing changed :confused: the northern allience still has no chance to get jobs

1 Like

But I tried to play with the others and they all function perfectly fine, just the NA :confused: i tried to disable mods but it wasn’t working :confused: but i can trie again later when I am back in my room

1 Like

You probably need to try on a new save or at least new citizens, as the game would simple save what buttons they have and not update after the mods changes


I’ll try that later

1 Like

But disabling UnitFramePlus should reveal the button in the citizens window, since that part is just a UI modification. It still doesn’t explain why it’s specifically failing with NA, but it’s a workaround to your current issue.

1 Like

So i tested in a new game with the NA without UFP and it works as expected. Dont know why only NA tho XD

1 Like

This happened to too, but I was playing Ascendancy

So I removed the mod that was causing this problem and everything was fine, except 20 minutes into a new mp game we both were unable to craft anything… Well, we play a vanilla game now it is fun regardless ^^