[Multiplayer] Error with Job Promotions

fixed_for_next_build

#1

Summary:
While playing multiplayer, some job promotions are not carried out properly. The Hearthling gets promoted visually and in their character sheet, but on the overall citizens tab, it shows they are still working their previous job.
Steps to reproduce:
Hard to reproduce exactly, as it doesn’t happen 100% of the time

  1. Run a multiplayer world
  2. Promote a Hearthling
  3. Wait

Expected Results:
The Hearthling to be promoted on the citizens tab and show a proper update, also has issues displaying correct task at times as well.
Actual Results:
Citizens tab is outdated and may show incorrect tasks.
Notes:

Attachments:

Version Number and Mods in use:

System Information:


Professions (carpenter,weaver,etc) listed as worker
#2

Can’t seem to edit my post, forgot to include a few things. Version number is latest unstable release R874, no mods.


#3

Does the citizen tab fix itself if you close and reopen it?


#4

I’m looking into this one, and it should be fixed by next release. For now, the list should refresh if you click one of the headers to sort it.


#5

Hey guys, wanted to follow up on this one as I’ve been experiencing a similar issue with this in single player & multiplayer.

Seems to be since the newest update of the game (Beta r874).

Summary:
Citizens tab is very buggy - to follow up from Merchaun’s point, the activity doesn’t update for the hearthlings nor does their promotions.

They still function as normal but when looking in the citizens tab there is no update at all. For example: a person could be mining or chopping down a tree and it would say they are either idle or talking to someone in the citizens tab when they are not. Another example being that when they are promoted, they stay as a worker according to the citizens tab when they are not.

Steps to reproduce

  • Run a normal world
  • Promote a worker to something and open citizens tab to see if changes from worker to relevant class OR assign worker to chop down tree, check citizens tab to see if activity updates

Expected Results
Activity description to update and promotion icon to change when promoted in citizens tab.

Actual Results
Citizens tab doesn’t update the activity description correctly nor does the promotion icon update.

Notes
I’m experiencing an issue with the escape key as well that doesn’t want to bring up the main menu after opening the citizens tab unless I press the key about 6 times, not sure if this helps identify the issue? I’m thinking it could possibly be connected.
I’ve tried testing out the citizens tab with Ascendancy, Northern Alliance & Rayya’s Children + all 3 maps - all have the same issue.

Additional things I’ve tried include:

  • Restarting the game after saving, this has displayed the promotion icons correctly but the activity descriptions still do not display correctly.
  • Reinstalling the game COMPLETELY from steam, sadly this doesn’t fix the issue.

To answer Relyss question - no this didn’t work for me.

Attachments
Unable to upload anything in here yet as I’m a new user :frowning:

Version Number and Mods in use
Beta r874 - tried with mods and without, same issue either way.

System Information
Don’t think this is really relevant at this current point in time, if you think otherwise feel free to let me know!

Personal Thoughts
I feel that this issue is hugely game breaking and is preventing me from enjoying the full extent of the game. My friend who I play multiplayer with has also been experiencing the citizens tab issue.

I guess I’m just going to have to resort to micro managing my hearthlings like crazy! :sweat_smile:

Let me know if you guys need any additional information from me regarding this and I’ll do my best to help.

Other than the bugs I just want to say, absolutely love the game and keep up the good work making this game awesome. You guys rock <3


#6

Yup, was about to report this myself, you can fix it by reloading UI, aswell as it doesn’t effect gameplay other than ui, hope this helps.


#7

Thanks @SnorrLaxZ - I can confirm this works :slight_smile:


#8

Awesome :smiley: Glad I could help.


#9

Appreciate the help from the devs and @SnorrLaxZ! Solved the issue!