[new_builder] Attempt to index field '?'

duplicate

#1

Summary:
An error window with some info.

Steps to reproduce:
I used the stairs tool near the vertical cliff. Supposedly while placing the stairs I dragged the cursor inside the cliff.
Another trigger was when I tried to pull stairs through other “ghost” blocks of a future building. Both times stairs started at ground blocks.

Actual Results:

While the error window was opened, I tried to use some tools (stairs, room). There was seemingly no effect. After closing the window all the structures I’ve tried to draw appeared. So while this error window is active, any building previews are invisible.

release-815 (x64)
...s/client/building_vision/building_vision_service.lua:265: attempt to index field '?' (a nil value)
stack traceback:
	[C]: ?
	...s/client/building_vision/building_vision_service.lua:265: in function 'up_visible_level'
	...hearth/services/client/building/building_service.lua:528: in function <...hearth/services/client/building/building_service.lua:527>

Version Number and Mods in use:
A24 r-815, only debugtools

System Information:
Win7 x64


#2

A post was merged into an existing topic: New Builder Stair Error


#3