Need Some Help Please

I am getting this when trying to launch the game
options can be specified on the command line using the format Stonehearth.exe name =1 value 1 name2 = value2 = name3 = value3
name should be the path to the property you want to set. For example to set this config file property: ’ renderer " : { enable_ shadows }
you would use: stonehearth.exe renderer.enable_shadows=true

any of the options specified in the stonehearth.json config file can be set this way and will override the config file settings.

Any help with this would be appreciated

Welcome to the forum, @crystastar :slightly_smiling_face:

Are you launching the game through Steam? If that’s the case:
Could you right-click Stonehearth in your Steam library, click on Properties, and click on the “Set launch options” button? If it shows some options written there you can delete them and click OK.

If you’re running the game through a shortcut, right click it and make sure the path it points to doesn’t have any weird characters or options next to Stonehearth.exe.

Did you ever change options in your user_settings.json or in the stonehearth.json file?

I an launching it through steam and went and deleted the launch option that it had in there. I also uninstalled and reinstalled and hoping it fixed the problem

Just sent you a reply from my phone . I deleted the set launch option stuff it had in there and i am launching it through steam and i never changed anything in there because i have no clue what to do even if i did lol . but i also Relyss uninstalled and reinstalled. will test it out and see if it launches for me if not i will be back here .

If it works Thank you for your help

It Worked YAY thank you very much Relyss for your help Kudos to you. Have a Wonderful day!

Any solution for a black screen ? I hear music just a black screen

Were you able to play the game prior to the launch options problem or is this the first time you’re playing?

Did you subscribe to any mods?

no mods and i played it before and it was fine

I am using windows defender and none of the ones were on the list i already checked

Could you upload your stonehearth.log? It should be inside C:\Program Files (x86)\Steam\steamapps\common\Stonehearth

Black screen usually means some other application is messing with the game (or with the UI process), but if you checked the list from Crashing on start? Read this! UPDATED October 18, 2016 I’m not sure what else could be causing it.

If you change "force_32_bit" : false to "force_32_bit" : true in your user_settings.json does it help?

Could running a 64 bit cause issues as well? And I will find the log as well

Once the music is playing in the black screen, does pressing F5 to refresh the UI help?

i changed the force 32 bit to true and seeing if that helps if not i will try to find the log file and upload it

the force 32 bit helped i see the menu now and now i can play ugh such a headache games can be sometimes lol
Thank you for helping Paulthegreat and Relyss

1 Like