[NaB]Alpha 7: "Trapper Ground" not being placed

Bug : The “Trapper Ground” is not being placed.

I try to create a Trapper Ground. I click the tool to make it. I click and drag over the area I want it to be. The red shows up, but when I release the button, it disappears. The Trapper doesn’t lay a trap, there is no red outline for a trapping zone. Nothing.

Steps to reproduce:

  1. Click on “Designate Zones”
  2. Click “Trapping Grounds”
  3. Drag out your zone and release

Expected Results:
I expect an area (indicated by a red-filled shape) for the Trapper to trap to be placed.

Actual Results:
The indicator disappears and you’re left with a normal mouse. To try again, you have to click the “Trapping Grounds” button again.

I tried it both before and after promoting someone to Trapper. I even demoted them and tried it again all to no avail. I never had this issue in previous versions.


Versions and Mods:
Stonehearth 0.1.0 (release 195) on Steam. I am currently running no mods.

System Information:
Windows 7 Home Premium | Processor AMD A8-4500M APU with Radeon™ HD Graphics, 1900 Mhz, 4 Core(s), 4 Logical Processor(s) | 6GB RAM | No dedicated video card

How big are you making the trapper gound?
You need to make it at least 10 x 10 in size, otherwise it won’t work (you can tell, when creating the ground, as the arrows by the measurments turn red when it’s too small).


i tested it just now and as far as i could tell that would be the only reason for it not laying down the trapping grounds.

That is the reason. I was not aware that was a requirement. Funny enough, it was usually just one foot shy of meeting it, but sense I make them in the woods it usually ends up at an odd shape.


Don’t worry, you’re not alone :sweat_smile:
I’m sure many people have thought this was a bug (myself included).