My StoneHearth crashes every 2-3 minutes in [Solved]

So I bought this game a while ago seeing youtubers play it. They stopped making a lets play of it so I stopped (Biggest Mistake Ever!) and now I tried to play it. It crashed every 2-3 minutes and I restarted my game re-downloading it to… still doesn’t work help please?

Welcome aboard, @TheMightyMichonne !

Could you post your system specs, please?

Do you play by Steam or did you download the Humble Bundle version?

Anytime I re-install Stonehearth or when the Alpha is updated, I delete the Stonehearth folder for a Clean install, prevents any layover problems.

Also being it’s Alpha expect bugs, lots of them, we be testing em for the nice folks at Radiant :slight_smile:

System Specs:

Processor: AMD A6-5400K APU with Radeon™ HD Graphics 3.60 GHz
Installed Memory (RAM): 6.00 GB (5.90 GB usable)
System type: 64-bit Operating System, 64x-based processor

I do play on steam.

Try deleting manually the Stonehearth folder (it’s located on your steam folder\SteamApps\common\

and reinstall again as @Unatan2 suggests. Also, go to your graphics card manufacturer’s website and check if there’s drivers updates for your graphic card. I know of lots of people having problems with AMD cards but there’s also others that have no problems playing the game.

Tell us whether it works or not. There are some other things you could try, and perhaps reading some threads about people’s crashes with AMD cards could give you more ideas to try.

Nothing worked :frowning:

If you deleted the folder you may have to tell Steam to download it again, depending on your settings, otherwise clicking on a desktop icon to start it nets you nothing

I did already… I am now running out of ideas maybe if I re-install steam which un-installs all my games which I could in-stall over night but if it doesn’t work its not worth it.

Try other workarounds in this post.

I’d check other threads and link you to them, but I have to go soon >_< (just search AMD crash in the search tool on the top-right of the forum page and you’ll find people with related issues)

Edit: Did you have the 64bit mode of the game activated in the settings, right? (If I don’t misremember, you can toggle this option inside the game now)


Could you post your user_settings.json file here after you crash? Thanks!

I cant. “Sorry, the file you are trying to upload is not authorized (authorized extension: .jpg, .jpeg, .png, .gif, .txt, .csv, .log, .obj, .qmo, .doc, .docx, .pdf, .xml, .evtx, .qcp, .qcm, .qb, .lua)”

Yeah, this is getting annoying. I have to zip all my uploads because even if I rename them to .txt they’re often too big - so I have to host them myself and link.

If yours are small, just change their extension to .txt and upload that.

yes, that’s more for security purposes on the discourse… if you can, please just upload the information to some free hosting service like dropbox, etc.

thanks! :+1:

1 Like

Thanks for helping me my game works now! I can finally enjoy it (:

1 Like

I’m glad you sorted it out :smile:

Don’t hesitate to post in the forum if you find any other problem :+1: