Muted game at random :(

a22r729
sound

#21

Also encountered the same issue. It appeared in a version before the NA update. The only thing I had changed before it happened the first time, was turning the music down, but not the sounds.

When starting a new game, the sounds always worked. When loading, it was 75% not, 25% yes.

Win 7; i5-2450M CPU @ 2,50 GHz; RAM 6GB; NVIDIA GT 630M 2GB VRAM
Using headphones without a mic.


#22

Yes, I am having this same issue as well. No sound when I boot up the game.

Specs:
Windows 10 Pro
Intel Core i7 4.5ghz
16GB DDR4 RAM
Nvidia GTX 1060 6GB
Rode USB microphone
Beyerdynamic DT-990 Pro headphones (plugged in through the microphone)


#23

Hmm, does running the game as administrator change that percentage at all?


#24

Will you try running the game as administrator and tell me if you hear sound?


#25

I lose sound occasionally but I know what causes it, switching focus to another window before the game starts.


#26

Now it both works in both administrative mode, and normal mode


#27

Hmm :thinking: How does one run it as admin through Steam, though?

Edit: Launching as administrator 4/4 tries - sound loaded successfully.


#28

You don’t. Either use the shortcut on your desktop, or go to the local files of the game through steam and use the stonehearth.exe directly. Rightclick on it, and choose ‘run as administrator’


#29

Similar experience here; any time I “click off” the Stonehearth icon while the game is loading I get sound loss. However, I’ve rarely had it happen even when I don’t switch focus.

I’m going to try running as an admin and see if that fixes the “switch focus” situation.


#30

I’ve been having this issue for quite some time when loading the game and I don’t click away from the window. It often takes me several tries to get the game sound going. Once it’s back on, however, I don’t lose it even if I switch away from the game window. It’s just getting the sound loaded to begin with that is sometimes a problem.

I’d say about 33% of the time, I have to reboot the game when I start it to try to get sound back. It happens at random, so reproducing isn’t really possible.


#31

Summary:
stonehearth’s sound only starts after one or two reboots very often.

Steps to reproduce:
in my case, start game as normal, notice there is no sound, alt-f5, start again untill there is sound.

Expected Results:
there being sound, consistently. every other game/application has no issue triggereing its sound.

Actual Results:
flakey sound

Notes:
this has nothing to do with ingame volume settings, or the PC volume setting. i change nothing between reboots of stonehearth and even when i have no sound, the settings say: there should be sound. but there isnt any.

Version Number and Mods in use:
latest, multiple. but it does this when there are mods, but also without.

System Information:
win 7 64 bit, intel 2500k, nvidea gtx 1060 6gb, 8gb ram

EDIT± also ive been having this for like half a year, i was always hoping it would just go away on its own…


#32

Today the sound didn’t work for me after tabbing away right after launching. I’ve never had a problem with it before (and I’ve tabbed away plenty.) I’m on r887.


#33

Was anything more discovered about this issue?

I’ve had a similar problem with sound and Stonehearth. Most notably after the game crashed to desktop for one reason or another. It can be virtually impossible to start the game with sound afterwards - without a PC reboot.
Sometimes however, the game can be relaunched fine after a crash - with sound etc.

Of note: on the occasions it fails to have any game music at the main menu, or any sounds once the game is loaded, the game is incredibly stuttery - estimated less than 1FPS. AI and core seems to be working fine in the background as I can see the hearthling’s path lines and can see the hearthlings going about tasks - albeit they skip around 20-25 tiles in distance between graphical updates. Takes about a minute and a half (once the game is loaded) before the UI appears or I can get the in-game menu to exit.

Is it related to the crash reporter in some way?

All system sounds work fine, music via steam overlay also works fine, just zilch from the game itself.

Tried running as administrator - no difference - didn’t resolve the problem.


#34

Were there other stonehearth processes running in the background when this slowdown happened? (There should only be 2 running, one for the client/server and the other one for the UI).


#35

See attached task manager screensnip.

stonehearth%20crashrep


#36

However, just tried manually deleting crash.dmp and also unchecked the ingame send anonymous feedback. This time just the 2 stonehearth processes, but same issue with no sound and 1fps.

I am now noticing the windows busy cursor and screenflicker to desktop a few times during loading the saved game and once loaded.

log indicates it to be:
game_engine | ignoring duplicate screen resize to (1920, 1080)

which is not something that usually appears in the logs. Indeed, it didn’t appear the first few times after I noticed the ‘no sound’ issue. It’s a new issue from repeated attempts to launch the game after exiting from within the game itself (not forcing it through task manager)

– Update.

after about a dozen launch attempts and trying various things, it has now loaded with sound and at usual load time. No difference other than having manually opened user_settings.json (no changes made and not resaved) so probably absolutely unrelated.


#37

Here’s something funny.

I’ve read this thread earlier today and thought “Interesting, that never happened to me.”

And now guess what happened? :jubilant: I guess the God of Murphy’s Law heard me and was like “O rly?”

Anyway, here’s another fun fact: The only different thing I did between always fine and it stopping working was change my sound output from the stereo to the headset. Changing it back to the stereo doesn’t fix it, but a PC restart did.


#38

Update again.

Accidentally crashed out to desktop again (because I was trying to place what I thought was a tapestry, but forgot I had that darned Wall Crest in my inventory) and now that problem is back again. No sound, really slow to load, 1fps when loaded.


#39

game_engine | ignoring duplicate screen resize to (1920, 1080)

This one is innocuous.

No sound, really slow to load, 1fps when loaded.

I don’t know about the sound issue, but if you get slow loading after a crash (of any program) it’s possible that either your anti-virus or Windows’ built-in protection is kicking in and doing extra monitoring. Try adding Stonhearth to the exclusions list of your AV.


#40

Added as an exception everywhere conceivable, but took a while to test as I was waiting for a crash to desktop that triggered the same situation.

Just happened, and still the same issue. Task manager after the crash is quiet and nothing using up CPU - other than the standard windows stuff and task manager itself.

Tried relaunching several times to no avail. However, simply going into the game settings from the main menu, and forcing it to resave the settings, then quitting and restarting worked. The next time I launched the game, sound and everything is back to normal.