Muted game at random :(

a22r729
sound

#1

Sorry, this will be a terrible bug report.

It basically happened at random.
I started the game (729) and it works fine, then some sessions later it was muted. Restarted and everything was ok again. Later, it got muted one more time, and again, just restarting it fixed.

When it got muted, it was muted all the way from launching the game and its start screen. Sound options were at 100%.

Maybe it is related with the audio changes and antivirus? Because in this new version (and the last one too), AVG stopped the first launch of the game to scan it. Following sessions were ignored, probably the av marked it as safe.


Sound only start after one or two reboots
No sound, but no crashes?
#2

@jamiltron :cold_sweat:


#3

Thanks for the report. I’ll take a look.


#4

So just to verify - the game stopped playing sound from launching the game itself, or was it from a session that was already up and running?

Sorry, I hate to be that guy that asks the obvious thing - but you happened to verify sound was working on your machine elsewhere while the game was muted?


#5

I was able to repro on 729 running from Steam. The first time I run the game after updating it, there was no sound. I restarted it several times and it happened again, but not very often, now I’m having trouble getting it to start muted again :confused:


#6

Started muted and kept muted until I closed it. The sounds was working in other places. When changing the volume windows does that “ding” sound, and it worked (the “ding”, not the game)


#7

Hmmm, let me try to repro.


#8

If you find it muted again, can you save and upload the save file and stonehearth.log? The save probably won’t help if restarting corrects it, but it may provide an additional data point. Thank you!


#9

Did you happen to disconnect your audio output device while playing?


#10

@BrunoSupremo are you using speakers, or headphones/headset? Is it a USB connection? Was it plugged all the time, or did you plug them right before the first time that you noticed the mute?


#11

It is a notebook, no external audio device being used.


#12

You aren’t using headphones, just the speakers? What OS are you running?


#13

Just speakers from the notebook. Windows 10, I believe fully updated.
The machine is an Acer e5-571-3513
i3, 4gb, intel graphics


#14

Can you do me a favor and go into Sound from the Control Panel, what’s your primary output device?

Did you happen to plug anything else into the computer not sound related, like a different mouse or keyboard or gamepad or something?


#15

Realtek High Definition Audio, if I understood correctly. It is the only one showing:

Although I didn’t added or removed anything, I have a mouse that sometimes fails, I believe it is a bad cable. Could that interfere here? When the mouse fails, I hear the sound of it being “plugged” again, which I didn’t remember happening in a while.


#16

I am not positive that it could be causing your problem, but it is good to know.

I have been able to replicate your issue on both the 32 & 64bit builds by starting the game with a usb headphone plugged in, then removing it. In this case, the game starts with sound, but then appears muted.

Additionally, if I start the game playing from my speakers, then I plug in the usb headset, it continues to play Stonehearth’s sound through the speakers, but all other Windows sounds through my headphones.

Also, neither of these seem to happen with traditional headphones, they work as expected.

It looks like the update to our audio library may be eating some of the Windows connection/disconnection events that may be causing this, but I am not 100% certain of this at the moment.

Thanks for the help. Me and @ayazar are delving into this and will hopefully find a fix soon.


#17

Hmm, so I’ve been unable to reproduce the game launching as muted.

I have found issues with connecting/disconnecting audio devices in general. I wonder if the faulty mouse potentially made Windows think a device was being swapped? I used to work a lot with all kinds of weird usb peripherals and bad ones caused very strange problems.

I’ll keep trying to replicate the muted-from-start issue, and if anyone else sees this please let me know.

Thanks for the help!


#18

hi guys

im sorry if replay at this post on september ends but i had the same problem.

No audio when launch the game.
i had try different way to “find” a solution but for now the only positive is the 32bit forced mode check in the System option in the game.

for me works and is the only solution por " fix " this bug (?) .
The bad news is that running game on 32bit is not a gooe game experience ( input lag, game slowing, less funny )

i hope someone can find a solution maybe and hope this was helpful .


#19

So when you run the game in 32bit the audio works, but not in 64 bit?

What hardware are you running? What’s your audio set up like?


#20

I have encountered a similar issue on an HP 15 laptop runnin win8: it would appear to be something involving permissions, as executing the game as an administrator as opposed to a simple start even on the administrative account seems to initialize the sound correctly.