Music when their should be none


#1

Summary:

Steps to reproduce:

  1. Turn music to 0% volume
  2. Tab out of the game in full screen mode

Expected Results:
No music
Actual Results:
Music plays at full volume
Notes:
Really annoying when I’m am trying to take a break and watch a video or listen to my own music.
Attachments:

Version Number and Mods in use:
Latest stable build.
System Information:


#2

Silly question, just to make sure: did you click OK to close the settings menu after you turned down the volume?
If you don’t, the change doesn’t apply.


#3

Yes restarting the game seems to make it go away for awhile then it randomly comes back.


#4

That’s so strange, I can’t reproduce it. Both ambient sounds and music have silence intervals from time to time to give it a rest, but them sounding at full volume randomly while the settings were applied at 0% volume shouldn’t happen.

I wonder if you had some other stonehearth process running in the background :thinking: (there should only be 2, one for the UI and another one for the game). This could be related to the other bug that the game starts with no sound randomly, since both have to do with the audio library.


#5

That’s indeed strange. Well I’ll just keep the game in windowed mode for now as that seems to make it stop. Also thanks for at least trying to fix this issue and reply back if you would like the one of the save files though I doubt it would be useful as it seems to happen in every save.