Multiplayer not working since ACE update

Multiplayer is not working after ACE

My friend and I started a fresh game when ACE 0.9.6 dropped, then some time between that patch and the current patch, it throws 30+ engine errors, when trying to connect.

Steps to reproduce:

  1. Start a multiplayer game.
  2. Invite to multiplayer game.
  3. 30+ Engine errors, within 30 seconds of the connection. Followed by crashing to desktop.

Expected Results:
To be able to play Multiplayer.

Actual Results:
Cannot play Multiplayer.

RMB on friend via steam friend list, and clicking join also does not work. Can connect only via invite from the host.
We have both tried fresh installs of the game, and re-downloading all mods in use.
Have also tried starting a fresh game, in case the save was the problem - to no avail.
The first engine error (see attached screengrab) seems to be talking about SHADERS… that seems odd - have also tried the alternative renderer.


stonehearth.log (50.5 KB)

Version Number and Mods in use: ACE
Glowy Windows
Crafter Queues
Bigger Backpacks
Combat Dash
Magic Combat
Extra Map Options
Footman Power Strike Balance
Kai Monkey’s Landmarks
Kai Monkey’s Traits
Box Command Tool
Lorkis Objects
Miner Profession
Home sweet Home
Fisher Job - Archipelago Biome
Taiga Biome
Canyon Biome
Sacred Grove Biome

System Information:
Win10 Pro, 64bit i7-4790k 32gb ram, Geforce RTX 2060

If you’re getting those shader errors, one or both of you is not using a version of ACE from within the past year.

We are both, however using the latest version of ACE from the workshop

Can you share your log? Are you video card drivers up-to-date?

The log is already attached to the bug report, unless you’re meaning something else?
And yeah, video drivers are up to date.

Ahh, I missed it there, sorry. Well, I see that version of ACE there in your log, but… I also see failures to compile shaders, referencing the deprecated ‘attribute’ keyword, and the ACE manifest overrides all those shader files with the updated ‘in/out’ keywords. So something in your setup isn’t properly installed or loading correctly.

All good, appreciate the help; any other suggestions?

We have both done a fresh install of stonehearth and the mods, which hasn’t resolved the problem.

I am the friend that’s trying to connect. I get the same errors and crash to desktop on two completely separate machines. Both had freshly installed Stonehearth client and no mods installed prior to connecting. On connection it prompted me to sub/download all the mods of the host like it always has, which works, then once past that and connected to the hosts game it throws the 39 engine errors then crashes to desktop.

Does it work without any mods? With just ACE?

Will give that a go and report back.

I’m having similar issues with multiplayer, any word on if you resolved your issue?

Nope, we gave up… tried verifying through steam, unsubbing to all mods, resubbing to mods, reinstalling through steam, completely deleting the folder and starting fresh. Nothing worked. :cry: