Engine Error when starting the game up using ACE 0.9.3.3

The Error I receive upon starting the game at the menu and when I either Load a Game or start a new Single Player game:
release-949 (x64)[M]
c++ exception: ‘startermod_items’ has no alias named ‘sample_buff’ in the manifest.
stack traceback:
[C]: in function ‘load_json’
radiant/modules/resources.lua:34: in function ‘load_json’
stonehearth_ace/monkey_patches/ace_catalog_lib.lua:67: in function ‘get_buffs’
stonehearth_ace/monkey_patches/ace_catalog_lib.lua:27: in function ‘_update_catalog_data’
stonehearth_ace/monkey_patches/ace_catalog_lib.lua:19: in function ‘update_catalog’
…hearth_ace/scripts/update_catalog/update_catalog.lua:5: in function <…hearth_ace/scripts/update_catalog/update_catalog.lua:1>
stonehearth_ace/stonehearth_ace_client.lua:111: in function <stonehearth_ace/stonehearth_ace_client.lua:106>
[C]: ?
[C]: in function ‘trigger’
radiant/modules/events.lua:55: in function <radiant/modules/events.lua:55>

I originally thought it was colliding with another mod(s) so I had deselected and unsubscribed from the mods, but there was no difference. I seems to come from the ACE 0.9.3.3 Mod itself. I’ve uninstalled every mod and the game, as well as reinstalling, Starting the the ACE mod first, starting the game up, and getting the same engine error. If anyone has gotten this, please let me know how to fix this.

Do you have that startermod_items mod? Seems like an error on it

That’s a hard no.

There is no reference to startermod_items in ACE, so it’s some other mod that has that reference and is causing the problem.

hmmm, I’ll have to go back and double check the mods again. The only time I’ve gotten that engine error is when ACE is one of the active mods.

ACE is probably the only mod trying to index buffs in that way, so unless the mod causing the problem actually tried to use that buff reference (e.g., spawning an entity that would start with that buff), you probably wouldn’t see an error for it. But ACE indexes all buffs on load so that more detailed buff information is cached and available to other parts of the game, like showing buffs and debuffs given/inflicted by crafted items in the workshop UI.

feel free to send your mod list, or even your save (it contains the mod list in it)

ACE (latest build)
Autoharvest Mod
Beam - Hearthling Stats Customization
Better Storage
Bigger Backpacks
Box O’ Vox (Complete)
Amberstone and Orc Job Expansion
Canyon Biome
Clan Amberstone
Cleric Combat
Dense Fields
Easy Mode Difficulty
Kingdom: Elves of Veloren (ACE Compatible)
Extra Map Options
Fisher Job + Archipelago Biome
Fruit &Animals (Box O’ Vox)
Greeklings
Hunting For All
Kai Monkey’s Traits - Version 3.51
Knacks Golemancy
Rabbit Burrows
Magic Combat
Nordlingmod [KINGDOM] [ACE+Vanilla]
Norsehearth
Obligation/Timer Tracker
Riallwood: Basic Template Pack
High Template Pack
Walls and Defences
Sacred Grove Biome
Skuldos: Basic Template Pack
High Template Pack
Walls and Defences
Smart Crafter
Space Magic
Super Mod 12
Swamp Biome + Firefly Clan + Beast Tamer
The Game Plague
The Great Ziggurat of Ur (Landmark)
UnitFramePlus
Vasedro: Basic Template Pack
High Template Pack
Walls and Defences
Wini’s Stonehearth Templates

You should disable Smart Crafter when using ACE, because ACE has it built-in.

As for the others, my mods (Obligation/Timer Tracker, UnitFramePlus) and any of Bruno’s, Dani’s, or any other really active modder, shouldn’t have a reference to the startermod_items mod.

Personally, I’d do a binary search by enabling half of the mods at a time and just going back to the main menu to see if the error is happening: if it’s not, enable half of the remaining; if the error does occur, restart the process with just the collection of mods you just enabled. Should only take ~5 tries to figure out what mod it is.

Alright, I’ll give that a shot.

i run many of those mods aswell except the templates and most of the biomes
box o vox and fruit & animals(box o vox) do not need to be active at the same time
I’m thinking it could be greeklings or norsehearth