Engine bug on startup


I was going to fuel my addiction and started up the lovely game however met with a demon-like text.

release-860 (x64)[M]
c++ exception: invalid resource ‘stonehearth/data/loadouts/loadouts.json’. File has a mixin to that is not formatted correctly!.
stack traceback:
[C]: in function ‘load_json’
radiant/modules/resources.lua:40: in function ‘load_json’
stonehearth/lib/catalog/catalog_lib.lua:72: in function ‘_load_json’
stonehearth/lib/catalog/catalog_lib.lua:78: in function ‘_load_entity_json’
stonehearth/lib/catalog/catalog_lib.lua:40: in function ‘load_catalog’
…ces/client/catalog_client/catalog_client_service.lua:11: in function ‘initialize’
stonehearth/stonehearth_client.lua:61: in function ‘create_service’
stonehearth/stonehearth_client.lua:87: in function <stonehearth/stonehearth_client.lua:82>
[C]: ?
[C]: in function ‘trigger’
radiant/modules/events.lua:55: in function <radiant/modules/events.lua:55>

I tried to reinstall aswell :thinking:

That’s a mod not compatible with the stable version. Join us on the unstable branch!

1 Like

@SnorrLaxZ to join the usntable branche, if you are on steam, right click stonehearth, select propperties, go to the betas tab and select latest (it funilly enough is usualy more stable than the stable :stuck_out_tongue: )

1 Like

But how about the mods that haven’t been updated to the unstable one :thinking:

The troublesome ones are those that added extra load outs, they will prevent you from making a new game. Most of the big ones have solved that by now though.

1 Like

Ah I see, thanks wouter!