Moving the view while loading a game can create errors


#1

Title:
Problems loading a game

Summary:
When loading my saved game upon restarting the game, I first got a fair number of error messages, and when I moved the camera around I only saw sky, only to finally find that I was way at the ground, perhaps inside it a little. I could probably have zoomed out to restore to a more natural camera position, but given my broken mouse wheel, could not manage to do so – but more generally, it would probably be a good idea to just have the camera be at either a saved position, or perhaps at the same position it’s in at the start of the map, or at a position overlooking your campsite, or some such.

The second time I loaded the same game, I turned out not to be able to move the camera either – and the game had frozen. To clarify, I could turn the camera using the right mouse button and the QE keys, but could not move it around the landscape either by mouse or WASD keys. (Of course, I still couldn’t zoom either, but I don’t know if I could have if my mouse wheel had worked.)

Below is a screenshot showing the error messages that popped up. Also, you can see that the instructional messages on how to move the camera reset, which is a very minor thing, but also probably not desirable. I figured I might as well mention them since they’re in the screenshot anyway.

Steps to reproduce:
I would assume:

  • Start a game
  • Play for a bit (probably optional)
  • Save the game
  • Quit the game
  • Load the game

Expected results:
The game loads with no problem and you can continue play where you left off comfortably.

Attachments:
Screenshot of the error messages & reset instructional messages upon loading.

Versions and mods:
No mods, latest release version in Steam at the time of writing, version 0.1.0 (release 80) according to the title screen.

System information:
OS: Windows 8 Pro 64 bits (6.2, build 9200)
Processor: Intel® Core™ i5-3450 CPU @ 3.10GHz (4 CPUs), ~3.5GHz
Memory: 8192MB RAM
DirectX-version: DirectX 11
Graphics card: NVIDIA GeForce GTX 660


[Dup] Loading Error
[Con] Buffs are not restored correctly while loading a game
#2

Thanks for the report! I imagine this falls into this category :stuck_out_tongue:


#3

Right! Well, at least now you have a bit of documentation on this one “in the wild”, so to speak. I’ve noticed one more thing which I will add to a topic and then I’m done for now, promise.


#4

absolutely… we should definitely expect issues with the system, but reporting what we’re seeing will absolutely help the team squash them…

and just remember, the more details you can provide the better! :+1:


#5

Right – isn’t the some kind of official format to publish these bugs in? I checked a few bug reports, but I couldn’t find it, nor could I find guidelines somewhere, but something like, expected behavior, observed behavior, steps to reproduce, system specs? I’ll try to look these up and use them properly in the future.


#6

There is indeed, right here:

@SteveAdamo we should probably highlight that a bit better maybe?


#7

Ah, now I see! I checked the “Category definition” post only, to be honest. Silly me. I did end up finding it just now elsewhere. Alright, let me see if I can edit my post here a bit, just to try it out.

EDIT: something like this?

EDIT2: I don’t know if it’s moving the view that generated the errors. I think the load itself just did that. But I will check later. Unfortunately, I’m already late to go to bed for now, so it will have to be tomorrow at the earliest.


#8

(Renamed for clarity.) Thanks for the feedback!


#9

bee-e-utiful! you just earned 2 internet points… :smile:

thanks for using the format… looks great!


#10

I reproduced it pretty quickly on my own box, so I think (hope!) that’s the only issue lurking here.


#11

Alright then, I’ll take your word for it.


#12

I gave the settlers commands to do after the game finally showed the terrain correctly after this bug, but they do nothing. They keep idling. You don’t even have to move the view while loading, doing nothing still shows the sky for a bit before loading the terrain.

Tried loading from Esc menu, and got this:

But still, settlers DO NOT RESPOND after loading.


#13

But you were at least able to move the camera, then, and give commands at all? I was not able even to do that, myself.


#14

Yes, I can move the camera after loading/continue and give orders, but the settlers do nothing.
Perhaps you can’t move the camera if you spawn into the ground? I remember the first time I loaded I was there but I think at last I was able to move the camera to the top.


Everyone Idle After Loading Game
#15

Perhaps, yes. I was able to rotate it. I don’t know if I was able to zoom, because my mouse wheel is broken, so that may have kept me stuck worse.


#16

Here too … some (Time) Problems … after the Loading …
http://imageshack.com/a/img841/761/jt7i.png
http://imageshack.com/a/img834/7917/hqoq.png


#17

When loading my game in the new version (0.1.0 release 92), I was presented with no error messages this time, but no visible land either, only the skybox and GUI. I have a new mouse with working zoom wheel now, so that’s not what kept me from getting out of this mode (I was in fact unable to move the camera around in such a way to get back to the game proper, though I could look around at the stars). I did not move the camera prior to this error, it was immediate upon loading.

Screenshot attached.

EDIT: another load and I was eventually able to suddenly spot land, then zoom out and continue my game. I think I did start out with more of a blurry green screen with only the GUI and the instructional camera movement tutorial messages, which was replaced by skybox immediately at the slightest movement. That may have been the case before as well, which would mean I missed it then, but I did think it was skybox right away.


#19

hey there @Dafaman123… prepare for a barrage of questions… :smile:

  1. would it be possible to post a screenshot?

  2. can you take a look at this thread, and see if you have any similar symptoms?

  3. does this happen with both the Steam and Humble Bundle clients?

  4. what are you system specs (specifically, your processor, memory and graphics card)?


#20

@SteveAdamo, I think it’s this other thread which relates to his problem.
At least it doesn’t throw an error and shuts up the game, so I think it will be savable.


#22

excellent… merged! :smile:

perhaps this is to be addressed in the next build (based on @not_owen_wilson’s comment)?