[MOD] Smart Crafter


Awesome thank you! appreciate the quick fix :slight_smile:


Experiencing that bug currently, on alpha 19.


Hmm, that’s no good. Though I’m having trouble actually getting this error, could you post some repro steps on this bug? Uploading your log file could help out as well.



So I guessed it was a mod conflict and it is, so I’m trying to narrow it down.

Edit: And now I can’t recreate! Ain’t modding fun?


It sure is!

If you manage to find where the conflict lies, please let me know. :slight_smile:

Den 17 okt. 2016 11:40 em skrev “lionsilverwolf” <


i have this problem everytime
release-687 (x64)[M]
…ices/server/crafter_info/crafter_info_controller.lua:42: attempt to index field ‘stonehearth:catalog’ (a nil value)
stack traceback:
radiant/modules/common.lua:237: in function 'report_traceback’
radiant/modules/common.lua:248: in function <radiant/modules/common.lua:242>
…ices/server/crafter_info/crafter_info_controller.lua:42: in function 'post_activate’
radiant/modules/common.lua:506: in function ‘create_controller’
…ervices/server/crafter_info/crafter_info_service.lua:15: in function ‘add_crafter_info’
…ervices/server/crafter_info/crafter_info_service.lua:11: in function 'fn’
radiant/modules/events.lua:288: in function <radiant/modules/events.lua:285>
[C]: in function 'xpcall’
radiant/modules/common.lua:257: in function 'xpcall’
radiant/modules/events.lua:285: in function ‘trigger’
…tonehearth/services/server/player/player_service.lua:59: in function ‘add_player’
…vices/server/game_creation/game_creation_service.lua:68: in function <…vices/server/game_creation/game_creation_service.lua:67>


Thanks for reporting the bug!

There are a couple of things I need to know though:

  1. What were you doing when you saw this bug?

  2. What other mods do you installed?


I’m getting the same error as the one above. I get it on the main screen as soon as I boot the game.


It seems to be a conflict with the settlementdecor mod. If I turn that off I don’t get the error.


Thanks for the extra info.

I just downloaded the latest version of settlementdecor mod to try it out, but I don’t see any error upon starting the game myself. Just to be completely safe (if you haven’t done so already), could you download the latest version of both mods and see if you still get the error? Thanks!


Currently when I load the mod into a created save, my first simple build ( with enough resources and lvls in my carpenter) will not be queued up at all, only 5 windows. Everything else just doesn’t go through. Any clue ?


Indeed, this one has plagued me for so long. With what else have been going on, I’ve forgotten about this, but it really must go. At least it can be dealt with by saving and loading, but it’s annoying.

You say though that you load the mod into a created save. Do you mean that you didn’t have the mod activated when first starting a game, only to activate it at a later time?


Yes, I litteraly worked around this by creating games and then reloading them with the mod activated. It worked in A19 haha


What should I do if I want the Smart Crafter to work in A20 ?


I was gonna say “same as before, just save and load the first thing you do with a new game.” But I tested it out a bit with A20 and bugs are popping up, so it’s currently not working with A20 at all.

I’ll take a look at it tomorrow though as it’s getting late here now. Stay tuned for further updates!


Yea that was kinda my point, I was expecting this answer in the first place. It no longer works in both ways I’ve found to be working and thought I’d report it as it’s by far my most utilized mod. It’s extremely useful !



This mod has been updated to work with Alpha 20. Also fixed the bug that forced the player to save and reload for each new game, it now works with each new game.

Look in the OP for the updated download links.



hey does this mod work with a21? or is for a19 and pre? because i’m looking to improve my game some but the current mods section always tends to have mods from a19 listed too even tho the most recent release isn’t a19 it’s a20 or a21. I’m on a21 myself.


So far I have only seen HOMF updated to A21, general rule of thumb on Modding, if it has a OP reply from months ago, its usually stale and not updated yet



Keep in mind, however, that many mods will not break between alphas. If a mod does not touch any major systems that have changed, in many cases they keep working. That being said, I haven’t tried using Smart Crafter in A21…