[MOD] Smart Crafter


Ill tell you if I brick my computer, OFF TO TESTING!!!


Yeah, as @jomaxro said, most mods manage to keep working in between alphas. And yes, I don’t usually spam my threads with something like “this mod still works with the new alpha release.” I tend to rather give status updates if something has happened with the mod instead.

Anyway, as you’ve also noticed (and for anyone else that’s interested): Smart Crafter didn’t break with the new alpha release. :slight_smile:


don’t even try this mod, it broke my crafting system so i couldnt craft anything


Broke it in what way? I’m still looking to improve this mod, so if you could describe how it’s breaking it for you, I’d appreciate it.


Basiclly it makes it so i cant craft anything, not even the workshopa


That sounds really odd, I haven’t seen this kind of problem myself. Maybe it could be some sort of conflict with another mod, what other mods are you using?


the only crafting mods i have are

tropical Island biome and
More doors


What is your total list of mods @Drotten is asking


Having the same issue if anyone has come up with a solution.
Current mod list is as follows:
Better Stockpiles
Chabonits jeweler
Stonehearth Cafe
debug tools
furniture expansion
Hearthlings of many faces
Locks of many (hair and clothes)
Settlement Decor
(Smart Crafter)
Terrain Colours
Unit Frame Activity Mod
Wizards mod

I’m still testing with these by disabling certain ones, but currently anytime I enable the smart crafter, it throws the same error and Im unable to craft anything.


Sorry for being absent; I haven’t had the time to be around in the discourse lately. But now I’m here and I took the chance to download the mods that you and WarLink posted to see if I can reproduce the error, but no luck; I can still craft the items as before.

Do you get any sort of error messages? In that case, what is it? Uploading your stonehearth.log file could help too.


When I put the latest Chabonit’s Mod, things happen.


Me too…QAQ


i’m having this issue tooooooooo and it’s happened in the past before.


Seems that more and more people get this kind of issue, I’ll look into it! But, unfortunately, I’m in the middle of exams and the last part of school projects, so it must wait until that is all over and done with. But it’s all done after next week, so by then I can spend all my time to fix this.

Also, for confirmation: @11181 and @Kitkat_Matt, are you using Chabonit’s mod as well?

Can't queue anything for the crafters

Yass I am! Very frustrating that that seems to be the common denominator.


###Status update!

So, took a bit longer than expected, but, with the help of Hyrule_Symbol, we managed to find what caused the error. It was because of a typo in Chabonit’s mod in one of its recipes. I sent a pm to Chabonit at least, so everyone who’s experiencing this issue will have to wait until he/she updates the mod.

As for this mod, there’s not much that can be done. The best thing I could do is to add an error message that shows up early if a recipe is not valid, so at least the confusion won’t be there should this happen again.


that’s awesome that you found out what the issue was at least. thanks for the hard work!


Sry to be the error maker.
I did that typo more than ones while creating new content. In the next release everything should work properly again.
Sometimes copy and paste works better then typing directly and get distracted. :slight_smile:


Are there any compatibilty probs with my mod and smart crafter atm…i lost track at which release it was and if i fixed it. But i read it in other threads.

Ok read through my release notes again
Prob should be fixed with R14.06


I don’t know if it’s a bug or simply this mod being incompatible with Alpha 22, but neither carpenter’s workbenches nor blacksmith’s forges are buildable with this mod active. The moment I deactivate this mod, they become buildable again. I expect there is more that is not buildable, but I only checked those two.