[Mod] Settlement Decor Mod [Download available]


#182

oh that is right, I remember you talking about that. No I am playing the Anorien biome. so that makes perfect sense.

Please…Please could you add this biome to the biome recipes list…:grin: when you get time of course.


#183

This is what I’m seeing. I unloaded every other mod just to make sure it was this one.

I think this is the same error message that I saw the last time an update didn’t work with this mod.


#184

do you have download the newest version?


#185

Yeah that is fixed with the newest version of Settlement Décor Mod. The last version broke in build 566 and a newer one is available.
http://discourse.stonehearth.net/t/mods-that-need-updating-for-build-566/23574


#186

Okay, that explains it. I haven’t been downloading from this thread so I didn’t know there was a newer version than the late June update. I’ve been downloading from Praise. The Praise entry is out of date then.


#187

Ah yes thank you for reminding me I forgot to update the praise version :grin:. I will be releasing another version later today so I will use that for the next update. Rather than do 2 updates today.


#188

Okay the new version is up now. I have added some new items to the desert biome gardener and weaver, changed plants so that they can be moved and behave more like the other plants in Stonehearth.

@Geokhan I have also added a solution for users using modded biomes. When using a modded biome it should now default to using the same recipes as those from the temperate biome. Though you may have to start a new game before seeing the changes.

I also tried adding the crops for the new plants to Rayya’s children, but a possible load order problem just makes the crop selection menu empty when I attempt to mixinto the rc_initial_crops file. :disappointed:


#189

:grinning: Thank you so much, I will try this one immediately.


#190

Version 1.00 is finally here and I now consider this mod to be finished. Though I may still need to fix some bugs and make changes to stay compatible with Stonehearth, I wont be adding anymore new features or items any time soon.

Continue to let me know if you find any errors even if its as simple as a spelling mistake or unusual collision region. Also I will continue to be open to suggestions on balance. Hopefully I will have some news about work on my next mod in the future.

Enjoy the mod and I hope people continue using it.


#191

First of all Thanks for making such an awesome mod.

But when I try to use your mod with Alpha 17 ( Release 584 )
it simply does nothing :-/

I don’t know if it’s a fault on my end or not.
All I did was drop your .smod into my mods folder and then I tried to start a new game to see if it works.

Only thing I tried is adding debugtools to see if I can see any changes made there.
But the campaign browser did not change for me.

Regards, protest


StoneHearth A17 Won't Launch *Solved*
#192

Not working for me in A17 either.


#193

tested and confirmed - doesnt work

reason: subfolder in the smod was renamed to settlementdecov100
solution: remove v100 from the name


#194

Thanks a lot, it’s working now!


#195

Woops stupid mistake on my part, forgot that renaming the .smod wouldn’t rename sub folder within it fixed now


#196

Well spotted Wiese, thanks for that!


#197

No Problem :wink: I have seen this issues to much in my own work at the start :stuck_out_tongue:


#198

the download here don’t have the updated renamed subfolder had to change it myself with WinRar


#199

thats weird because it worked fine with me


#200

He updated it after the issue was pointed out, so it’ll work as intended for everyone now :slight_smile:


#201

Are we allowed to modify this mod.