[MOD] OneLaughingLlama's Modding Corner - UPDATED + NEW CLASS FORESTER


#21

Lookin’ Good :smile:


#22

Agree, awesome mod!
To make yourself truly divine, can you make it so it needs an item (one from the stockpile) to plant an sapling? I tried that myself once. But could not properly destroy an item. Got all kinds of errors.


#23

I will gladly give it a go.

I think that my problem will be implementing the requirement of the sapling, rather than the destruction of the sapling. Let me have a day or two to fiddle. If you have the files you tried with, send them through. Or even the files you edited, PM me the names.

Regards,
OneLaughingLlama


#24

I dont have it anymore. But what I tried was basicly this.

After surveying battleground (vanilla), pick_up stone. Go to place on hunter area (vanilla), drop item (vanilla), destroy_stone. The rest was the same I think.

I will pm you the files I edited. But dont go on what I made :smile:. I am no coder. Might be requiring some completely other approach.


#25

Update

  • Forest, moveable and modpack updated to latest version
  • Garden by itself is no longer supported. It will be part of the modpack.
  • Small changes to the mods

#26

Have you tried looking into the deletion of the carrying item?


#27

Hey @Miturion

In the latest mod, the forester will get the sapling and consume it to place a sapling.
Have a look at the forester mod itself if you are interested in how its achieved.

This is potentially resource heavy, I need people to tell me how it works long term.


#28

Ah cool. Thanks for the effort. :thumbsup:
This will open up a way to do some nice chain production.

edit:
Works great, awesome mod. Much more fun when you actually need some materials as input.


Mods that should be added to Stonehearth as Standards
#29

Forest for r162 doesn’t load. I think it’s because the version is 1.1 and versions (as of right now) can only be Integers. When I changed it to 1 it worked.


#30

it worked for me.

(grumble 20 chars)


#31

Maybe you are using the modpack which has a version of “2” in the manifest? Forest by it’s self is “1.1” and gives this error in the log:

2014-Nov-24 19:28:33.454003 | server | 1 |                        resources | Module forest version 0 is out of data (expected: 1)

#32

Yes I did use that one.


#33

this been updated to alpha 7? throwing errors on forest


#34

is this mod still going? if so can we get a rock tree ? lol


#35

heyho an little update possible?


#36

I would also love an update :slight_smile: but if you dont want or have time to work on it please tell us :slight_smile:


#37

I’ve wanted to move Silkweed and Berry Bushes since I found this game a month or so ago. Very sad to see that Moveable doesn’t seem to work with 2560. :sob: How exactly are these things supposed to be moveable? When I click on them, there’s no move option as with other things.


#38

Hi there @OneLaughingLlama. Great set of mods here that need a bit of updating. I’ll volunteer if you need help with your mods. :grinning: Cheers!


#39

@OneLaughingLlama was last seen the 28 of july. He is probably either busy with something else or have just stopped coming on the forum as a general thing.


#40

Thanks @thorbjorn42gbf:wink: As long as no one minds, I’ll see what I can do with updating of the mods since these are “classic” and I do hate to have great mods just fade away.