MIning update is horrible, ruined game for me

Ive attempted the “new” mining. It is such a pain in the rear to line things up. I always end up one to high or one to low. I have to zoom in to get it to line up then I cant expand due to being to close. Honest to whatever god you worship, I hate this play now. Mining is a major part of the game if I cant do it without a college degree in engineering and programming… whats the point of playing it? The game is suppose to be user friendly and its not anymore, well atleast in the mining part. I will check back to see if its ever fixed but as of now, Im done with the game. Its not fun getting all frustrated trying to get the mining lines to line up.


Mining in “slice” view mode is super effective, but otherwise yeah, it can be a pain to line up the start of a mine in the side of a mountain (the 3D outline of the entire mine area box including the part that’s inside the mountain is really disorienting for me).


Sorry you’re frustrated! We’ve long felt that the old mining tool has a lot of restrictions, but we put them there because it’s a real challenge to manipulate things in 3D (see any 3D modeling program). After learning some stuff from the new builder, we tried applying some of it to the mining tool, with mixed results. A lot of the powerful features make it hard to make simple shapes. We’ll take another look at it next week.


I tried the sliced view to see if it was easier to get things to line up. It ONLY works if your on the level the slice allows you to view. If your on a number one higher than the slice… then its no good again. your mining wont line up, you cant continue on the end of your tunnel (the box will not line up and when you think it is… its actually no where near your tunnel.
The game is a very user friendly EXCEPT for the mining now. They have taken a fun easily learned game and taken one of important sections of it and made it complicated, difficult to learn, difficult to use and… there is no guide on how to use it. The direction box that pops up doesnt tell you even half of what you need to know to use the new mining tool and since its rather large and centered on your screen… makes it very difficult to even to try to use the mining tool. Completely frustrating. I wish I could undo this update and go back to the last update.

I’m not sure I understand you, since the old miner could only mine on those slices. Are you talking about mining one voxel higher than the slice, or one “slice level” higher? For the latter, the slice you’re looking at can of course be adjusted by the arrows on the slice view tool, and for the former I think you would’ve had the same trouble with the old miner. If you’re trying to continue on an existing, offset tunnel (i.e., not aligned to a slice), does the X-ray view help at all?

cant really say i feel the same. you do have to change habits though, where previously you just aimed willy nilly, now you have to aim at a block in a wall…

a ctrl-z would be nice though, for when you -inevitably- mis click.


I understand what the issue is, and I’ve experienced the “lining up” issue myself, but it’s nothing that can’t be tweaked a little and improved with some positive feedback.

Getting hostile with the developers won’t win you any friends. These guys are doing an awesome job pumping new features in and they’re really gaining some momentum. Of course if you play the unstable branch you’re going to run into problems. Why don’t you go back and play stable and wait for these new features to be tried, tested, tweaked and improved before being put into stable themselves as a working system?

If mining is getting you so frustrated that it makes you want to quit, the unstable branch of an early access game isn’t for you. :roll_eyes:


There’s a lot of criticism here and not much constructivenes. Help us fix it by explaining how you think it can be improved and not why it sucks, instead of focusing on the negative or blaming the developers

I agree that the new mining tool is a tad clunky “lining up,” as you all have said, but overall the tool is LIGHTYEARS ahead of the two previous iterations, and its immediate transparency ability that allows you to mine tunnels “on the fly” (quoted from Angelo on stream) is glorious.

IMO, Perhaps if there were a UI window that let you increment/decrement the sizing (picture like the slice tool) it would help those who have trouble scrolling.


Your mention of the new building tool gave me an idea - would it be possible to use something similar the new building tool to “build” mining areas? Go into the mining tool, drag out the flat “floor” of the mining area, then expand it upwards, for instance. Drag out “rooms” that are the area that will be mined, be able to resize them and move them around, erase bits from the designation, and so on, and once you’re happy you’ve got the mining designation you want, you can hit “go” and the actual orders to mine the stuff out will be issued.

Not knowing how stuff works under the hood, it seems like that might be a relatively “cheap” way of getting a powerful mining tool while making it easier to adjust things when you want to mine out complex areas.


Thoughts, so far, after literally two minutes messing around with it:

I miss the old single block mining tool - perhaps there could be a button to change the size to 1x1 x1 immediately? And perhaps to switch to the 4x4 x4 preset as well.

I’d still like to see the ability to mine stairs, which is what I find myself doing the most often.

I’d like a “planning mode” or similar that set new mining zones to be suspended automatically, so you can have your Hearthlings only swarm the place for mining later and not while you’re still laying it out. Especially because you often can’t pause in multiplayer.

Edit: Played a bit more, and I don’t like the offset for the selection cube. I’d much prefer if you selected the top cube, or maybe even the bottom cube - or, beyond my wildest dreams, a toggle. But in the middle means you’ve got to find just the right cube on the edge to select when you’re trying to line it up with a surface.

Further edit: Okay, maybe this instant feedback thing isn’t working out well for me. Looks like you can line it up with the top of a surface by pointing at the top side of it, rather than the side of the top cube. So that’s nice. A way to line it up the bottom of the selection with the layer below would still be nice, though. Also, further edit: This is still a bit finicky. Off-topic, sort of, but what’s also fun is that I can’t Fn+F12 to make Steam save a picture of what I’m doing while holding the Ctrl needed for subtracting parts, but that may be my laptop’s fault.