../lib/build_util.lua:158 invalid normal(..) in normal_to_rotation()

After achieving the new tier II of building I tried to create a Tavern which then I tried to customize because it was empty. After few upgrades the engine error popped up and the game won’t let me place the thing or any other. Cannot even remove the “blueprint” from the place.
Steps to reproduce:

  1. Clicked the Build button
  2. Selected the Tavern and placed it
  3. Tried to customize it because it was empty
  4. Error pops up and the blueprint is unremovable

Expected Results:
I wanted to add tables and such to the Tavern to decorate.
Actual Results:
The blueprint became unremovable and uncustomizable
After the error I jumped into the last autosave (Love that feature!). I tried to remove or customize the blueprint but nothing really happend. After a while the engine error screen stopped showing when I tried doing the same thing. The savefile did’nt become corrupted (luckely!).

Version Number and Mods in use:
release - 701 , Alpha 20
System Information:
Windows 7 64bit, (can edit the rest if needed)

Similar issue here, but my building glitched on placement. (Never mind the wolves coming to eat my hearthlings.)

I can post the code if need be.