Kobold Elite Hat won't pick up and then disappears [Steam Forum]


I saw this item drop and it stayed on the ground, couldn’t get any settlers to go and pick it up to add to my inventory, my inventory slots weren’t full so I suppose it was because it was far away I don’t know. The item has vanished and I can’t seem to obtain another one. Needless to say I can’t complete the Gong to further the missions. I’m writing this in hopes that someone has a workaround, I’m also writing this so the devs can be aware of this and put something in that allows the mobs to spawn again in case it was missed. Thank you all for taking the time to read this.

Hmm…I haven’t tried progressing that far in the campaign in A19, but this definitely worked in A18. The hats drop from the ambient kobold threats in addition to the campaign, so it should be possible to get more simply by fighting them as they appear…

I think the poster was more concerned that it disappeared after a while and couldn’t be looted. I assume they know how looting works if they got that far in the game, afterall. Perhaps it was a bug in how enemy loot drops work and it just happened to occur with an important quest related one. No idea. I just figured it might warrant some looking into if there is a bug in loot drops.