Items like workstations and furniture won't deploy and remain as ghost items

It was fine in the beginning of the game, but now 3/4 of items that I try to put down won’t deploy. Of particular problem right now is workbenches. I’ve sold them to clear them out of my inventory, built them again, and then tried to redeploy but still no one will put it down. What can I do?

I’ve experienced the same thing. This usually happens late-game when you have a high number of hearthlings.

Saving and reloading the game solved this for me every time.

Just reloading as in restarting the game and loading the old save? I tried that but it didn’t fix it, either. I’ve also tried destroying it, selling it, creating it again, and redeploying. I am having a very hard time with this. I only have 17 hearthlings and I’m not experiencing lag or anything

Hey there @Altrich, welcome to the Discourse! Can you upload the save where this is occurring so the devs can review?

To upload a save, locate the folder in
C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install), zip the individual save’s folder (not the entire saved_games folder), and upload it. If the *.zip is less than 10 MB, feel free to upload it directly to the Discourse. If larger, please upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.