Can't deploy monument


Made a Monkey Monument, isn’t being deployed after several restarts. It shows up as undeployed in inventory

Steps to reproduce:

  1. Made Monkey Shrine Momentum
  2. Potter went to sleep after it completed
  3. It will not deploy


Version Number and Mods in use:

No mods, Alpha 19 x64

System Information:

i7 6700k
Windows 10 64

Can you find it in a chest or anything, I have a fur rug in this situation. It shows up in my placeable inventory and i inventory, but with 3 in game days they wouldn’t place it, I can’t find it in a chest, and I can’t sell it. Not sure if it’s the same situation.

Welcome to the forum, @Dohregard :slight_smile:

If you upload the savefile we can take a look at it. To upload a savefile:

  1. Find the save folder for the saves you wish to upload. By default, they are located in C:\Program Files (x86)\Steam\steamapps\common\Stonehearth\saved_games (assuming a default Steam install).
  2. Zip the folder.
  3. Right click the folder (should be a long set of numbers).
  4. Left click on Send to in the menu that appears.
  5. Left click on `Compressed (Zipped) folder).
  6. (Optional) Rename the folder to something different than the default set of numbers.
  7. Upload the save.
  8. If the zip is less than 10 MB, you can upload it directly. Either use the upload button or drag and drop it into the compose window,
  9. If larger than 10 MB, upload it to a cloud storage site like Dropbox, Google Drive, File Dropper, etc. and post the sharing link here.

@paragouldgamer, other cases where an item is not being deployed are:

  • a hearthling has it inside his backpack, and nobody can place it unless it is dropped first;
  • the item is on a container that got undeployed and is now inside another container (bug which hopefully will be prevented by a fix devs made for Alpha 20)
  • the item has disappeared magically (this would also be a bug, any help on how to reproduce that is welcome :slight_smile: )

Thought there was a good chance this was my problem as I have recently put down alot of vaults and took up some smaller storage items. Placed every storage item from my inventory on the ground and all had 0 in it. Also couldn’t figure out how to undeploy them when they had something in them. Thought perhaps I picked up a crate that had the fur rug and sold the crate, but couldn’t undeploy another crate while it had an item in it to test that.

If you want to try your luck at it the save game is at

I also used the town alert and checked all the backpacks (and those of the military) and didn’t find the rug in any of them. I don’t know when I made the rug. I use 4 saves and just overwrite them, checked the 3 previous ones and all had the missing rug.

Also tried: dump_inaccessible_items
Came back with 0 items.

I think I know what happened in your case, @Dohregard :slight_smile:

This was the key, since the monument wasn’t inside any of the storages.

This is a bug where, if the crafter gets interrupted right after they finished crafting, they will leave the crafted item on the workbench (it will disappear when you craft another of the same item, but you will lose the one that got stuck on the workbench).

In this case, since the kiln is so huge, we couldn’t see the item, but if you try to make the camera go through the kiln, you will see that the monument is still there.

Unfortunately, I don’t know of a way to retrieve it from there, so you might need to craft another one :sweat:
I reported this to the devs some time ago, and Linda has fixed it so that the crafters should never leave items on top of their workbenches again. This fix will be in when we release Alpha 20.

Not sure about @paragouldgamer 's case. When dump_inaccessible_items returns 0, it shoud mean that the item is iconic at some place, and maybe the hearthlings can’t reach it for whatever reason.

I removed all your buildings, and went to the placement UI and placed all the rugs from there and now there are 6 rugs on the floor. However I have no clue of where the missing rug is. My guess is that it might have fallen on top of a wall or on a roof or some other place that makes it hard to see where it is.

1 Like

A good way is to click on the item and teleport it out of the workbench, i suppose clipping the camera through the ceiln will allow you to click on it, after you select the item hit ctrl+C to open the console and type teleport and click on a location outside of the workbench

Yeah, I tried but clicking inside the kiln would select the kiln anyway :disappointed_relieved:
It’s worth some tries, though. Building the monument again requires getting all the resources…

Have you tried moving the ceiln? It might leave the monument behin

Moving and undeploying (checking with the potter’s wheel too). The item respawns on top of it anyway, I think it became a child entity :confused:

Thanks for all the help. It didn’t really bother me since it’s just a fur rug, glad to know it’s not just bugged out of existence though.