Items blocking workshops and other weird behaviors

I’ve had a few issues with workshops, sometimes materials or finished items end up blocking the workshop, nobody in the settlement would pick them up, nor the assigned settler would work with the item if it’s a raw material.

I’ve removed the workshop, but placing it again would result in even weirder behavior, the item on top of the workshop would respawn along with it, but float various blocks above it, a bed that was floating above the carpenter workshop somehow managed to be picked up and placed on the ground, unblocking the workshop to be used again, no such luck with ingots or spools of thread in the blacksmith or weaver’s shop.

Tried also destroying the weaver’s shop to see if that helped, but it just ended up completely destroying the citizen management window as shown in the screenshot, you can also barely see the bronze ingot somehow sinking into the anvil:

The ingots in the blacksmith shop and the spools of thread in the weavers shop are likely from items they are attempting to craft. If you have some of the materials, the crafter will bring them to the workbench in the hope that some more will be found soon. If you want them to take them off the bench, you need to go into your crafting window and cancel the task. It could also be from your stockpiles getting too full and the crafter having nowhere to put the item, so they just kinds of toss it down anywhere nearby. It might randomly be on the workbench again.

I can confirm the other bug though.

Using the “Clear” zone action or the “Destroy” console command to remove workshops breaks the citizens window. You also can’t place a new workshop. This is a likely explanation for many of the people complaining about broken citizen windows on the steam forums.

Hopefully it wil fix itself in alpha 12 when the new workshop system is introduced though. Since workbenches aren’t tied to individual crafters, you shouldn’t be able to break the citizen window by deleting one. Hopefully. Someone at radiant should probably look into it!

Well, if you see to the bottom right of the screenshot, there’s another huge stockpile that has space left for more items, so not having the space to remove it wasn’t the problem.

The spool I’m not sure if it was just crafted or was waiting to be used in another thing, but I know for a fact the ingot was a product and not a material for another crafting task, yet none of my workers would pick it up and remove it from the anvil.

The second stockpile was a general one too? I only see food and silkweed bundles in the picture, so I can’t tell.

Yeah, it’s another general one, I don’t do specialized stockpiles because I’m just trying out features every time I open the game up, last time I tried to go big an awful bug just prevented me from fully enjoying the game

Have you tried setting the second stockpile to “none” and then “all” again? Have you tried making a third stockpile? I’ve heard of them getting a glitch seldomly. If we can narrow down the bug by eliminating a bunch of things that didn’t cause it, it makes it a bit easier to find a cause.

I’ll try it next time, I closed that particular session because it was doomed anyway, items were still being deposited on that second stockpile anyway, just not getting cleared from the workshops for some reason