Iron pikes not being stocked

Traded some stone with merchant for couple of iron pikes. They were placed outside the storage area and close to the starting firepit. Could not pick them up or move them. thought maby it became part of the banner so i moved that and the firepit. My villagers moved the iron pikes to the storage area, but still no luck picking them up. Also they don’t sparkle like the tools or sword, so not sure in what catergory they fall. The don’t show up on the inventory list though.

Steps to reproduce:

  1. wait for a trader to offer it
  2. trade the requested items with the trader
  3. wait for the iron pikes to be placed.

Expected Results:
movable, useable, show in inventory.
Actual Results:
they stay where they are, no usages.
added the save file. Screenshot shows the iron pikes moved to the storage area after i moved the banner and firepit.

magnolia iron pike (3.9 MB)

Version Number and Mods in use:
release 529 mod debugtools
System Information:
win7 64bits gtx 650 8g ddr3

Also in this save file there is a small part of scaffolting my villagers wont remove. Its below the lower stairs on the right side of the wall. Not sure why they wont remove it. I have seen an improvement on scaffolting usage so hopefully it is something minor.

hey there @Doc_Brano,

what weapons do your footmen currently have equipped? also, the provided save is acting strange for me, whenever it try to load it up, it just goes back to the title screen…

Currently, Footmen always pick the strongest weapon. If they have already something stronger than the Iron Pike like a giant Bone Axe, then they simply keep the axe.

I don´t see any footmen in the screenshot. Do you even have some?

1 Like

This save is on peacefull, no footmen assigned. Sword do sparkle even in peacefull game. Save game is the complete map just like it is on my pc. saved the game again and did not change the name of the folder, maby it will be different (3.8 MB)

for completion purpose i added the scaffolt pic

well… footmen are the only ones who use pikes, or any weapons for that matter.

assuming you mean the wooden sword, its a talisman so it will sparkle, but the pike is an "upgrade"so it wont sparkle, same as all the other weapons.

this save loads fine, must have been the renaming that caused the issue.

so all in all, this appears to not actually be a bug, thanks for the report though :slight_smile:

well there is still the issue of it not being dropped in the storage area in the first place :). That makes it a bug

1 Like

right, forgot about that part :stuck_out_tongue:

just updated the title to be more fitting towards the issue.


I am confused…loaded up both saves, and the iron pikes seem to be in the stockpiles…

yes they are at the save, but they were originally placed at the starting flag like all items you traded with a trader. But the iron pikes were not moved tot the stockpile like is common after trading. Only when i moved the flag and firepit did they move the pikes towards the stockpile.

I know it was better to have the save then or a screenshot but i never worked with iron pikes and was unfamiliar wat they were. When they placed it around the flag they almost formed a square around the flag. Thought it became part of the flag as they would not move them to the stockpile and they did not appear like normal tools do. Only after moving the flag i noticed this was not the case.

1 Like

Interesting…so it was almost like the Iron Pikes were “stuck” to the flag. What type of trader did you encounter (standard buy with gold, instant caravan, delayed caravan)? I am going to try and reproduce the issue…

it was one of those give me this amount of crap and i will give you a certain amount of crap. I believe it was 16 wood for 3 iron pikes.


after moving the flag and firepit the iron pikes remained at the original point and were not moved. So calling that stuck i’m not sure @jomaxro

1 Like

Oh :frowning: that will be very hard for me to reproduce.

In response to your edit: yeah, stuck isn’t the right word there.

1 Like