I STILL get the idle workers bug (ALPHA 8)

I stopped playing a while ago because of the idle worker bug basically making the game unplayabale, and lo and behold, it’s still here for me in alpha 8. I set my workers a task to build a house and they completed most of it then stopped and stayed idle (they were outside the building), I told them to build a road and they stayed idle, I tried to reassign one to become a footman and again they just stayed idle and didn’t take up the new job. S’kinda annoying.

UPDATE: I’ve found the only thing they WILL actually do is gather berries, but they won’t carry them to the stockpile. Also my farmer and trapper are both working fine, it’s just my workers and carpenter who are affected.

Okay I’ve just solved my own bug (yes, make fun of me if you will -.-). Basically the problem came when building a road below a ladder; the workers couldnt climb up the ladder to the next level to get the stone and wood because of the empty space made by digging out the road. I’ve heard of some other people having similar issues, so hopefully this isn’t just a public display of how moronic I can be sometimes :wink:

1 Like

Idleness is definitely an issue still, there’s a few people with the problem - I’ll merge this into the other thread (I’m pretty sure there’s another thread…)

I’d agree that it’s definitely one of the more frustrating/ game breaking issues - but we just have to stay strong, keep our fingers crossed, and hope that Team R are able to resolve it bit by bit with each build.


It kinda sucks that those of us who are technical can play the alpha but don’t get to see the code or contribute to it. There are all sorts of bugs in [r2193] that are from a broken locking/semaphore model. There is nothing I can do but watch :expressionless:

1 Like

I get this bug too, I also get flooded with error messages followed by a crash :frowning:

What sucks most is that the idle workers bug has been around for +6 months and they haven’t fixed it properly yet. I mean, it’s not like its some minor annoyance, it makes the game totally unplayable! :stuck_out_tongue:


If only it was that easy to fix eh :stuck_out_tongue:

I believe it’s a part of ongoing pathfinding issues rather than just simply being an idling issue. All part of the Alpha process unfortunately.

I know, but it’s still insanely annoying when it happens, moreso than most other bugs (except for a new one i’ve found, where Hearthlings get stuck on top of an object until they die of starvation -.-)

I am pretty sure this is all in the LUA if I had time to extract it and learn lua… but I am guessing from the various bugs that I have seen that the scheduling model for the game is incorrect, or the model is correct but the locking mechanism is poorly implemented.

For example, when an agent goes to sit, it should be presented with a list of chairs that are EMPTY. When an agent sits in a chair it should lock the chair blocking other agents from sitting in that chair/seeing that chair on the empty chair list, obviously this lock is not in place. This lock used to be in place, but it’s not now. I am guessing this is because all the various agent locks are in various parts of the code… this is also why agents now all go for the same object. It might be even worse, maybe there were no locks, and pathfinding was used as an implicit lock and now that cached/shared pathfinding has been implemented, all the implicit locking breaks. This sort of problem can easily happen when people over optimize or optimize early.

I actually think you guys are at least decent devs and know all this already, so I am not sure who I am writing to, please don’t be offended :smiley:

Actually, I wrote all this because I would love to talk though these design issues, but I can’t really commit to coding them up. maybe someone in the modding community would be interested in submitting the patches…

You are writing to a lowly moderator with no coding knowledge or experience I’m afraid :slight_smile:

My knowledge lay in other areas! Like card making, and crochet. I also throw a mean bubble party.


Yeah, the idle workers from broken ai/pathfinder is what keeps me from playing more. I get maybe twenty guys in my town, then at some point they all just decide to break themselves and its just not fun anymore. Really hope that this issue gets fixed by the next couple alphas, it stops me from building anything beyond a few basic houses and such.

Let’s not forget we’re still playing an Alpha! Bugs aside i’m still floored at the content we’re recieving at this point! Yeah there are going to be bugs…it’s an Alpha…I think they’re trying to get more content out in to see if some of the discovered bugs will be fixed. If they spent a ton of time fixing bugs we’d never have a game :wink: Not trolling/hating just making note of the amazing fact that THIS IS AN ALPHA GAME! :open_mouth:


I’ve been following this game since way last year and just recently bought into it and am amazed at how far the devs have come. If it weren’t for the save/crash issues, they’d have quite the playable game even at this stage.

1 Like

I have had thesame issues as described, but for some reason, sometimes I can activate town defence and then deactivate and they all resume their duties.

Try it out and let me know ifit works for you.


Still seeing this error in Alpha 10 x335