I need help for my mod!

I created a mod, and It’s mod include a new clas [Jewellery] and I tried to make for this class a recipe, but when I start the game, it writes 2 error to the recipe.

Somebody can help me for this problem?

The MOD link [this is BETA MOD yet]:

Thanks the helps [ :smiley: ]

Could you please upload in another service? Mediafire hates me, whenever I click on the “I’m not a robot” and then on the next button, it just reloads the pages…
You can zip the mod and upload the *.zip here, which is even easier than using those download services.

I don’t get any errors with your mod. Are you using components from other mods? And could you maybe post the Errors here.

I created another LINK: Dropbox - magical_jobs.smod

1: I use components for my mod, because I didn’t knew, how to create a StoneHearth Mod.
2: I upload some photo from the error.

You have a missing comma at:

You can check for the code integrity using the http://jsonlint.com/ site.

Besides, in the manifest you told the game that it is version 10. Take note that it is not the version of your mod, but the version of the game api, which right now is 3.

1 Like

I change this things [thanks for help :D], but I get another error:

This is the manifest:

The recipe will give an item, but that item is not in the manifest. (check the recipe and manifest, you used different alias in each)

This is the “gold_gem” folder / the item json file and the recipe:

At your manifest you used “refined:gold_gem” while in the recipe you are asking for a “jewellery:gold_gem”

It’s worked! Buuut I have a last problem:

This is only the workbench, but nowhere the gem.
This is the mod folder now:

You locked the recipe.
At the gold_gem recipe, you used this line
"manual_unlock": true,
With this, the game will not start with that, and only after an event, like a quest or something else you code, the recipe became available.

1 Like

It’s work!!! :smiley: Thank you so much the help! :wink:

Can you have any idea, how can I create models without Qubicle program?

I use VoxelShop and MagicaVoxel, both free.

VoxelShop can work with multiple layers (matrixes) which is used for animations and have good tools. But have bad lighting and colors, like when you color your model, then in-game it does not look the same way.

MagicaVoxel has very few tools, doesn’t support multiple matrices, but looks very good while editing, with great light and colors almost like in-game, which is good when choosing the correct color palettes or taking screenshots of the model.


This programms are amazing! But, I found a funny thing:

The outfit a little bit wrong :slight_smile:
Are you have any idea, how can I fix it?

1 Like

You will need to correct the export settings.

I use MagicaVoxel, but I don’t know how can I set the correct settings. Can you create a photo, how can I do that?

I think MagicaVoxel can’t edit outfits, because it does not offer support for multiple matrices.

This is the carpenter outfit, opened in VoxelShop. See at the bottom right all the layers, each is a individual piece of the model, and they need to be separated that way so they can animate. (Like move one foot up and the other down to create walking motion)
When you open it in MagicaVoxel, it merges all models and it becomes a single, inflexible piece that can’t be animated, it is all a single “solid” piece.

1 Like

I tried, to create the outfits in the VoxelMap:
When I tried to load game, the game is crashed, with this message:

This is the export options and the 2 outfit [normal/female]:

The error message: