I can't select a different language

resolved

#1

No idea what is happening, with the portuguese mod. There was no change to it since the last time I updated it.
I activated the mod through the mod menu, and when going into the system menu to chose a different language, clicking on the “english” button does nothing, no options are being displayed.

Is it just me? Something I did in the mod maybe?

This is the mod: portugues.zip (459.6 KB)
It is also giving error when trying to update to Steam.


#2

Thanks for reporting. There seems to be some problem in the js file, it’s trying to retrieve the language files from a wrong path (it detects the language, but can’t load the en.json). :disappointed_relieved:

Will ask Linda. This is probably some issue with the optimizations to the settings page.

Not sure about error when trying to upload to Steam. Is there a message?


#3

The error was too generic, no idea what is the problem:
image


#4

Strange indeed. :thinking:

I wonder if Steam had some trouble? Lately I caught two times the issue where you couldn’t explore the workshop because no mods were shown.

I don’t think we pushed any of the changes to the mod uploads yet so it shouldn’t be that.


#5

Linda said that the dropdown menu wasn’t showing on top of the UI. Hopefully that’s it (I tested with the German translation and it loaded fine).

About your upload error, are you sure that there was no error message next to the namespace in the Mods menu? Sometimes it takes a while to sync with Steam, so it says invalid steam file ID for some seconds.


#6

There was no visible problem. But I tried one more time and it worked, the only difference step I made was that I did not edit the name and description this time.
I always have to edit it because when updating any mod, the text fields are pre-filled with information from steam in your preferred steam language. So the texts are filled with the portuguese name and description of the mod, but when submitting the update, the texts end up updating the steam english version.