(New) translation problems

Hi guys,

like last time (long time ago) i have a little problem about translation mod.

First, i lost my file so i have to translate it from the start (i already translated the first 1000 strings in half a day so its not a big problem).

The biggest problem i have is that, probably my fault, i can’t enable the mod translated.

I do all the steps to activate it:

  1. i create the translation file, naming it it.json (the translation is italian)
  2. In manifest.json i change the string
    "overrides": {
    “stonehearth/locales/en.json”: “file(translations/stonehearth/en.json)”,
    "overrides": {
    “stonehearth/locales/it.json”: “file(translations/stonehearth/it.json)”,
  3. i put the it.json file in the translation mod AND in stonehearth/locales
  4. in added_languages.json i put:
    “languages”: {
    “it”: {
    “display_name”: “Italiano”
    …and should be done…
    As i said i translated the first 1000 strings (more or less) but in options—>system it should appear the “Italiano” word (with “english” word), instead the “Italiano” word doesn’t appear…

The problem is a mistake or something i missed (much more probable), or its because the new version 3?

ps.: the translation already worked with version 3, but now not…

1 Like

You can test your files with www.jsonlint.com to see if there is any errors in it.

If you get nothing, post it here so we can check the files.

1 Like

I already tested them…i try again. Otherwise i send my .smod file

1 Like


link for my .smod file

edit: i forgot to say this: i named the translated file as “it-IT-json” and as “it.json”. Some thing.

1 Like

You zipped the files, but they need to be inside a folder. The main folder is then zipped, and that zip is renamed to .smod

1 Like

?? Shouldn’t be the mod file (.smod) zipped and in the “mod” folder in the main folder of the game?

The files are zipped in a unique .rar. This .rar (trad_ita.smod) is in “mod” folder (with all the other mods)

1 Like

What I mean is that inside your .smod you have the files manifest, added_languages and the folder translation. You have to add only one folder inside the .smod, and inside that folder is where you place the manifest, added_languages and translation folder

1 Like

Oh, lol right!
I try it now.

1 Like

Lol ok it works. Ican see it in Option —> Mod, but it says “Invalid Manifest”. Ill check it.

1 Like

What I did was:

Inside the .smod, a folder named italiano.

Inside the italiano folder have the manifest.json, the added_languages.json, and the translations folder.

1 Like

Thats what i made (i called the folder “it” but i don’t think its important). The problem is the Invalid Manifest, but i don’t know why… the names are ok…

1 Like

My smod and the main folder inside it are both named italiano, I tried having the .smod named something else and it failed. So try that. have both with the same name.

italiano.smod with a folder named italiano inside, and inside that all your files and other folders.

1 Like

LOL it works!

OOOOK i said bullshit…names ARE important…


1 Like

The otalian version works fine??

Hi, if u mean mine then yes (i don’t know if there are others making the italian translation) and for now the only way to download my translation is from youtube. But its not completed yet cause of the latest updates and i don’t have much time to finish it. So i think i will do that in some days.

Yes your version, i’m not sure if someone is working on it right now. If you need it maybe i can help you with the missing translations

well, if u want to help its ok for me.


This is the link to the download of my translation.

1 Like

Ok, i will take a look on it :smiley: