How do i make the blacksmith remember her job

ive got all the ore she needs she wont do her job tho so i cant make any swords or shields or NOTHING grrrrrrrrr lazy blacksmiths these days

Hire a slave master.


First, make sure you have enough wood. All the smelting ingot tasks take wood in addition to the ore.
Second, did the Blacksmith get stuck on something and then you moved that job somewhere else in the queue? He’ll still be stuck on that job. Once a crafter has started a job, he won’t quit unless you delete the task from his list.


Further to @Tuhalu 's post above, I’d suggest completely clearing the blacksmith’s queue and then re-adding the ingots you want again, checking that the ores and wood are available in the stockpile (not lying around).


Looks to me that your blacksmith hasn’t leveled up yet to make swords and such. Keep making ingots to gain xp

thats what she wont do she absolutely refuses to make anything

Based on the screen shot you have it set to maintain 2 of those ingots. As SpareGoblin suggested, clear the queue and tell the blacksmith to build a ingot you know you have the ore for. Since you have it on maintain certain ingots if you are missing resources for one of those it will not continue down the queue.

on another note are trappers pets worth anything ?? are they useful in anyway or just a waist of pathing processing right now

and day three of damun is how far into the calandar?

well i tried clearing her (cue) and she still wouldent move (idle) so i tried demoting her to a worker and got any hints as to whats going on im just going to start over on this map but this map is for my twitch stream

That first screenshot is wierd. It’s an error in the ladder builder service.

I’m just guessing here, but it kind of sounds like your hearthling had assigned himself to build a ladder somewhere and when you demoted him it broke the code that handles that (or it was already broken and the demotion made it more obvious). Did you have some unbuilt ladders in the world somewhere?

nu no busted ladders just half built houses

Well, the scaffolding in a house always includes some ladders, one on each corner for the hearthlings to climb up on. It could have been one of those. Were some of the houses failing to build all the way or did you just try and build more than one house at a time?

failed build (manuall completed “ib”)

1 Like

I haven’t tried to instant build something that was already halfway done before. Was there any scaffolding left over from that?

The other error really doesn’t mean anything to me either, but could simply be a consequence of the ladder problem.

nope once i instant built it they took all the scaffolding down and were able to path thru the houses without a problem

Well, that’s about all I can think to ask about then. With luck, maybe something can be sorted out.

A lot of people have had random errors changing classes back to worker, but it is rarely the same error, so I imagine the devs are having trouble nailing that problem down.

yea and the head between legs issue is odd as well