How do I change the base models for Females or Males?

So, I downloaded Stonevox, (real nice BTW) and extracted the female model from the Stonehearth mod, and added a small amount of voxels to it. I saved it in the Stonehearth mod folder. I started the game and found that the textures were not overwritten by the hexes in “skin_brown2_material_map” or anything. Please tell me what I am missing or misunderstanding because I inevitably am.


The model color should be exactly what the game expects else it will not find it to replace with the desired skin color. Also, if the hearthling existed before, it will probably not work, it needs to be a new hearthling.

1 Like

Do you mean like a new save? What do you mean by “a new hearthling”?

Have a read through this document, and try making a simple mod with the tutorial within.

When you load a game, there are many things that will not be updated. So some code will not reflect the changes you made. You would need to spawn a new hearthling, or simple load a completely new save, to check these changes.
I’m not sure if this would affect you, just one thing to consider.

1 Like

Ok thanks!

I understand your point that I should do that, but adding something to the game is different from changing something in the game.

So correct me if I am wrong, first, it checks to see if the colors match the colors selected in “skin_color_map.json” file, then if it matches, it changes the name designated in “skin_color_map.json” to the color selected in “skin_brown1 (or other)_material_map” which appears on the body of the hearthling. but if not all of the skin material map jsons are correct, none of them will. please tell me if I got it right or if I got it wrong!

So, I know I am not using the wrong colors in StoneVox, but, if I simply, and only export the base body model, open it in StoneVox, save it, then export it without making any changes, then popping it into the Stonehearth mod folder. When I opened up Stonehearth, the same problem happened.

Strange, check if the same happens if using Voxelshop:

I might have import/exported the body.qb model wrong, but I got this error in the roster.

In the voxelshop? In the export settings, uncheck the compression.

So I got it to work from your suggestion, but now the clothes are out of sync.

I’m facing this same problem with voxelshop. I will check later some other options

I got Qubicle, it solved the problem. But One thing that I don’t understand is that with StoneVox, when I added an unknown color, or changed the model at all, (same with magicavoxel and voxelshop) it changed the in-game color to be the same as the selected color in the model editor, so the color override code didn’t work with those models. weird.