I updated a model in my mod, but the game still shows the old model

The old model is not anywhere in the mod as far as I know, and for some reason the item stamp still gives me the old model.

Symptoms (in order of time):

  • reloading with updated mod: stamper shows old model.
  • importing the .qb files into voxelshop: shows new model.
  • rezipping, re-smodding and reloading te updated mod: stamper shows old model.
  • deleting all objects in the save that had the old models: stamper shows the old model.
  • deleting all objects in the save with the old model, new save, exit game, rezip and re-smod and reinstall updated mod, starting game and loading up this new save: item stamper shows old model.

ARG :angry:

Something that might be it (???),

  • There are .qmo files in there. But I’ve read that stonehearth ignores them, so I doubt that that is the reason.

Does anyone know something I missed, is there some stupid reason that my mod behaves this way?

Your json is pointing to somewhere else. Also, just delete the unused files like the qmo

Done,

But this doesn’t fix it (no bad feelings, I’m just observing here)


Sorry Bruno, but I doubt that this is the case.

I have no clue what it could be but i could try to load it in my stonehearth to see if it is a thing about the smod or just stonehearth that bugs for some reason.

Because form the files its should just work ^^

If you could do that please: :grinning:
I sent you a message with the .zip

What about the other json, if they have a qb they will override the info in the ghost.

“Bronze_ingot_pile.json” contains the following:

{
   "type": "entity",

 "mixins" : "file(bronze_ingot_pile_ghost.json)",

"components" : {
  
	"stonehearth:entity_forms" : {

                        			     "iconic_form" : "file(bronze_ingot_pile_iconic.json)",
         
             		              "ghost_form" : "file(bronze_ingot_pile_ghost.json)",

                                         "placeable_on_ground" : true
  
                                           },

	  "region_collision_shape" : {

                                                       "region": [   {

					                                "min" : {
							                      "x" : -1,
							                      "y" : 0,
							                      "z" : 0 
							                         },

					                                "max" : { 
							                      "x" : 1,
							                      "y" : 2,
							                      "z" : 2
								                 }

						                }
]

			              },
            "stonehearth:resource_node": {
                                              "task_group_name": "stonehearth:task_group:harvest",
                                                     "resource": "stonehearth:resources:refined:bronze_ingot",
                                       "harvest_overlay_effect": "stonehearth:effects:mine_overlay_effect",
                                             "harvester_effect": "mine",
                                                  "description": "mine",
                                                   "durability": 24
                                            }
          
   },

"entity_data" : {

               "stonehearth:net_worth" : {

			                    "value_in_gold" : 288,

					           "rarity" : "common",
				     
       "shop_info" : {

					                             "buyable" : false,
					       
                 "sellable" : true,

				                            "shopkeeper_level" : 1,
			              
                   "shopkeeper_type" : "caravan"

						               }

				      }
          
    }

 }

and “bronze_ingot_pile_iconic” contains this:

     {
   "mixins": "stonehearth:mixins:item_properties",
       "type": "entity"

“components”: {

     "model_variants": {
		           "default": {

			            "models": [ "file(bronze_ingot_pile_iconic.qb)"

]

				       }

		        },

	       "mob" : {

		     "model_origin" : { 
					 "x": -0.05,
					 "y": 0,
					 "z": 0.05 
				       }
			 }

	 }

}

What is the alias that you are using to stamp it into the world? Does it point to these files? Maybe it is pointing to some other json

This is the line in the manifest:

"bronze_ingot_pile" : "file(entities/ingot_piles/bronze_ingot_pile/bronze_ingot_pile.json)",

and there is excactly where aformentioned .json is.

Although it must be said that @Yangzhoui did not manage to get the mod to work at all on her device. I suspect it is the [Add][Object] (I would not know otherwise what it would be.)

Could it be that my game remembers the models from the last time the od worked. That would explain why the mod works for me (although no updated models), while Yangzhoui only gets the recipes, but not any model.

No that can’t be it, I added the treasure/gold chest today, and I got it in succesfully, so that can’t be it.

Alright so i dont know what it is but for some reason i can not use the stammper to place item but the items seem to work just fine in game.

This is the model i get when making the bronze ingot pile

I think the stamper is the corrupt here because all files are okay

Maybe the stamper cant handle the in the file name

That is the wrong model, you see, it needs to have 3 layers, not 4.
(4 levels means that it’s the old model)
Can you try importing it into some voxel editing program.

I double checked that I did have the right model exported, but it imports just fine with 3 ingot layers, no extra (empty or otherwise) in the editing program

nope it has 4 layers in qubicle

so i think it goes wrong in the export of some sort

All .json is valid as far as .jsonlint is concerned.

I think it must be something with inporting and exporting then.
I can senfd you the .vsd files

The problem has been resolved

1 Like

And the problem was…

My own stupidity,
I was to hasty in replacing the files, apperantly.
It still doesn’t explain why I could suceesfully import the models from the mod, to show 3 layers instead of 4, but it works now, so I’m not complaining.

Anyway, thank you @BrunoSupremo and @Yangzhoui for helping me hunt down the issue, even if that issue was my own stupidity.

3 Likes