High Quality Graphics for HD 4000 Graphics?


Why is the high quality graphics option disabled?

I have a decent Core i5 Cpu with 8 GB Ram
Running an HD 4000 Integrated Graphics which works darn good for other games.

I am running Windows 10 64 x bit

Have you tried ticking the box?

1 Like


It seems to be grayed out.

That’s odd, I’ve never heard of that being greyed out before… @yshan or @Albert, is this intentional?

Pinging @not_owen_wilson

Not vetted response:
I think this might be a shader limitation or something where an integrated graphics card will crash the game because it doesn’t support the functionalities we use in the high quality graphics.


I also have this hd4000 and my options is also greyed out. In my case I wouldn’t be able to enjoy it anyway cause although is the same video, my cpu and memory is way lower, i3 with 4gb

I spoke with @not_owen_wilson
He says to make sure your graphics drivers are up to date. Please update your drivers and then see if the option becomes available.

1 Like

After updating drivers, if it is still greyed out, please upload your most recent stonehearth.log file from your game directory. By default that is C:\Program Files (x86)\Steam\steamapps\common\Stonehearth

It’s an issue with the hardware. Any integrated cards can’t handle certain high end graphical functions no matter the game they are on.

My old hd3000 had the same issue with any game that tapped into certain shaders and such

1 Like

stonehearth.log (429.4 KB)


Hi hope this helps - please let me know if you can tell anything from em logs.
Would be cool if I could enable the enhanced graphics - enjoying this city builder a lot. may upgrade my laptop but only 1+year from now.

It is actually one of those ASUS S400CA Ultra books

  • 8 gig ram
  • upgraded to a nice SSD hard drive
  • core i5 3317U CPU containing an HD 4000 Graphics Integrate Chip … works well with similar titles

P.S Have you tried out a game called SurvivalCraft by Kaalus @ Rufus Games? very very good one.

Not seeing anything there that sticks out to me in the logs, you’ll need to wait for @not_owen_wilson to come chime in. As to SurvivialCraft, no, I’ve never played it.

What I said earlier was relayed to me by @not_owen_wilson (he’s not coming in person basically XP)

@Ian_Coetzer please update your graphics drivers here: Downloads for Intel® HD Graphics 4000
And then see if the check box becomes enabled


1 Like

I spoke with Chris,
The drivers need to be higher than build number
According to the logs above, @Ian_Coetzer has

Try using the site I linked for drivers?

I could be reading the linked site wrong, but based on the release notes there (https://downloadmirror.intel.com/25977/eng/Readme32.txt) is the current version for that card.

Darn, don’t think the newer drivers support my chipset HD 4000 (3rd gen).

ok managed to find a slightly newer one … will try it out now. but other than that i cannot find a never version to test.

That number indicates that it is older than 4358 < 4425.

ha ha true, going back to good old …4425 both are too old to enable the high quality graphics.

1 Like